My Tractor Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
I got a great deal on a NOS power flow and mc519 cart for my x748 se with 60" 7 iron deck today at a dealer going out of business. I started the install this afternoon and the cart was assemble without issues, but the blower assembly has me confused. The front mount install I am sure is correct. The back mount where the pin sticks into is the questioning. I have no hole for that support rod to fit into. If anyone has this setup and could take a pic or two at the back mount that would be great. I did get a small bracket and self tapping screw with the kit that I think I need to use. Any help is appreciated.


Sent from the MTF Free App
 

·
AKA Moses Lawnagan
Joined
·
4,644 Posts
Might help to post some pictures of the hardware; every deck type is slightly different, so how it mounts on one might not be the same on another.

I wish I had the 7-Iron deck, the one regret I have with the setup I have. I have the 54C deck on my X748SE, it's a good deck, but the 7 Iron can handle taller, heavier grass better.

This is how the blower for my PowerFlow attaches at the back, on the 54C. There is a hole in the right rear bracket for the antiscalp wheel, and the pin on the blower assembly mates up with it. The drivebelt tension is what keeps the blower tight against the chute opening on the deck. Not sure if this will help you, but here it is:
 

Attachments

·
Registered
Joined
·
60 Posts
Discussion Starter #3
That's exactly the pic I was looking for, but the 7 iron doesn't have a pre drilled hole like that. I will post pics when I get back from dinner


Sent from the MTF Free App
 

·
Registered
Joined
·
438 Posts
Mark the deck where the pin hits it and drill a hole. There have been other installs that the instructions have you drill a new hole or enlarge a hole already there.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #5
Mark the deck where the pin hits it and drill a hole. There have been other installs that the instructions have you drill a new hole or enlarge a hole already there.
That is Probably what I am going to have to do. I think I figured out why it doesn't match right up though. Apparently there was a serial number break in 7 iron decks, this power flow is for the older deck, I have the newer deck. I looked on JD parts and I cannot find a different power flow kit, I'll probably call the dealer tomorrow about it see what they say.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #6
I still haven't figured this out yet. I have installed the blower assembly according to the manual, but the belt rubs the rear gauge wheel bracket.
 

Attachments

·
Registered
Joined
·
345 Posts
Is there some ducting missing between the Power Flow and the deck?

Have you verified the part number versus application to be sure that you do have the correct kit? It sure looks to be riding too low. I Only have my older setup to compare too, but the belt rides pretty level horizontally.

If you get a chance could you take a measure of the overall width of the deck with the blower?
 

·
Registered
Joined
·
60 Posts
Discussion Starter #8
I have all the parts outlined in the kit, they are installed, called the dealer and looked on JD parts, there is only one kit for a 7iron deck on the X7s and this is it. Now I didn't install the blower chute up to the cart yet, maybe that will help align it a little?
 

·
Premium Member
Joined
·
6,408 Posts
Is it possible the power flow has to be mounted on the forward part of the deck opening rather then the back portion?
 

·
Registered
Joined
·
345 Posts
Some more pics of your setup might help.

The Powerflow blower should attach securely to the deck. On my older unit there was a bracket that went up inside the deck at the rear. A large 5/8"-3/4" or so rod from the powerflow slid into this bracket and a "cam buckle" grabbed a boss up front securing quite well. The plastic shrouding rides up on top of the deck a bit closing off the gap on the top, fore, and aft. Looks like you have a lot of open air between the blower and the deck that should get shrouded off.

I found some pics here that show it how it is shrouded off and also the angle of the belt. It looks like yours is riding low and to the rear of what I might expect.


http://www.mytractorforum.com/showthread.php?t=128864
 

·
Registered
Joined
·
60 Posts
Discussion Starter #11
The front edge is closed off by an extra baffle under the deck, however the rear has an inch gap between deck and blower shroud. I'm going to install the chute and see how it goes after that, I expected a more refined fit for this attachment.
 

·
Premium Member
Joined
·
6,408 Posts
The Powerflow blower should attach securely to the deck. On my older unit there was a bracket that went up inside the deck at the rear. A large 5/8"-3/4" or so rod from the powerflow slid into this bracket and a "cam buckle" grabbed a boss up front securing quite well. The plastic shrouding rides up on top of the deck a bit closing off the gap on the top, fore, and aft. Looks like you have a lot of open air between the blower and the deck that should get shrouded off.

I found some pics here that show it how it is shrouded off and also the angle of the belt.

http://www.mytractorforum.com/showthread.php?t=128864
That link shows a 54" deck???
 

·
Registered
Joined
·
345 Posts
That link shows a 54" deck???
Yep, different deck, but it shows two different versions and more importantly how the unit slide in tight to the deck and closes off the gap.


It would appear as though the later units use external rods without anything to clutter the inside of the discharge chute.
 

·
Premium Member
Joined
·
6,408 Posts
I got a great deal on a NOS power flow and mc519 cart for my x748 se with 60" 7 iron deck today at a dealer going out of business. I started the install this afternoon and the cart was assemble without issues, but the blower assembly has me confused. The front mount install I am sure is correct. The back mount where the pin sticks into is the questioning. I have no hole for that support rod to fit into. If anyone has this setup and could take a pic or two at the back mount that would be great. I did get a small bracket and self tapping screw with the kit that I think I need to use. Any help is appreciated.


Sent from the MTF Free App
Are you sure that is the right power flow for that deck?
 

·
Premium Member
Joined
·
6,408 Posts
This is a (60D) Blower, is that what is suppose to fit that deck?

 

·
Registered
Joined
·
60 Posts
Discussion Starter #17
That is what I have, I looked up the jd parts diagram as well to confirm the correct blower assembly. I was hoping to find someone with the same setup, who could chime in and offer some pics, or opinions. the belt clears if i push the whole assembly forward and bend the rear rod a little, but this increases the gap at the rear between blower and deck.
 

·
Registered
Joined
·
6 Posts
I have this EXACT same issue. 1023e with the 60D 7 iron deck. No hole for the rear rod and the belt is going to hit. I was going to look at it this afternoon. I did find a document showing the baffle and Z bracket installing in the front of the opening so that I'm sure it correct but the rear sure doesn't make sense then. I'll run to the Deere dealer down the road over lunch today and see if I can find anything helpful. I'm really glad someone else has the same issue (sorry).

Brad
 

·
Registered
Joined
·
60 Posts
Discussion Starter #19
I have this EXACT same issue. 1023e with the 60D 7 iron deck. No hole for the rear rod and the belt is going to hit. I was going to look at it this afternoon. I did find a document showing the baffle and Z bracket installing in the front of the opening so that I'm sure it correct but the rear sure doesn't make sense then. I'll run to the Deere dealer down the road over lunch today and see if I can find anything helpful. I'm really glad someone else has the same issue (sorry).

Brad
I'm glad I'm not the only one, like I said before there were two styles of decks, and the older ones had the hole in the rear. These newer versions aren't as easy though. Any help is appreciated, my dealer told me I would have to bring it in for them to look at it, but I've been busy.


Sent from the MTF Free App
 

·
Registered
Joined
·
6 Posts
So I talked to a really sharp guy at one of the JD dealers in my area this afternoon. He told me that if my Power Flow unit SN starts with GX700PF then it's the correct unit for the 60D 7 iron deck. That made me feel better. I was missing the bracket that you apparently have that attaches to the rear wheel bracket. That was item M159551. Once I get this we'll see how close I'm going to be but from everything I've seen it looks like belt will rub against that bracket like yours. He said it shouldn't but until I get the bracket I won't be convinced. I'll update you in a day or two when I get the bracket and fully install it. In the meantime check your serial number on the Power Flow. I did ask a couple of guys if there was more than one version of the 60d and they each said no. I'll get back to you in a couple days.

Brad
 
1 - 20 of 26 Posts
Top