My Tractor Forum banner

1 - 7 of 7 Posts

·
rollingthunder7
Joined
·
21 Posts
Discussion Starter #1
Went to do my 50 hr. service on my X590, drained both front and rear drain plugs and changed
filter.
Per owners manual it calls for 5.6qts of oil, when i went to refill the trans it would only take 4.5qts.
Ran tractor forward and reverse and used the hydralics and the oil level stayed right at the full mark.
Has anyone else run into this, I will keep an eye on things, but can't understand why it only took 4.5qts
instead of the 5.6qts the owners manual calls for.
thank you
 

·
Super Moderator
Joined
·
15,728 Posts
Went to do my 50 hr. service on my X590, drained both front and rear drain plugs and changed
filter.
Per owners manual it calls for 5.6qts of oil, when i went to refill the trans it would only take 4.5qts.
Ran tractor forward and reverse and used the hydralics and the oil level stayed right at the full mark.
Has anyone else run into this, I will keep an eye on things, but can't understand why it only took 4.5qts
instead of the 5.6qts the owners manual calls for.
thank you
Keep In Mind Your Power steering & Hydraulic lift cylinder still have Hydraulic fluid In it. Even when You change the Transmission fluid:thThumbsU
 

·
rollingthunder7
Joined
·
21 Posts
Discussion Starter #3
Thanks for the reply, could that be the reason I only put in 4.5qts of oil instead of the 5.6qts like the manual states,
never thought of oil being in the power steering and hydraulic lift, I suppose that doesn't drain out when you drain the
transmission.
thanks again for the information
 

·
Father Deerest
Joined
·
2,716 Posts
Normal, if you empty the entire hydro system and re-fill it then it will take 5.6qts. Keep an eye on it and just keep it at the full line.
 

·
Registered
Joined
·
3 Posts
Went to do my 50 hr. service on my X590, drained both front and rear drain plugs and changed
filter.
Per owners manual it calls for 5.6qts of oil, when i went to refill the trans it would only take 4.5qts.
Ran tractor forward and reverse and used the hydralics and the oil level stayed right at the full mark.
Has anyone else run into this, I will keep an eye on things, but can't understand why it only took 4.5qts
instead of the 5.6qts the owners manual calls for.
thank you
Same thing happened to me! And filling the transmission is a royal pain in the ___ !
 

·
Registered
Joined
·
3 Posts
That it would! I cobbled something together and got it done. Also overfilled the reservoir in the process by mistakenly referring to the owners manual for capacities. :rolleyes:
 
1 - 7 of 7 Posts
Top