My Tractor Forum banner

61 - 65 of 65 Posts

·
Registered
Joined
·
1,452 Posts
Part # on shock I removed is AM147167 which shows is wrong on Deere's parts website.
Correct. M808782 is the correct shock for the X590 (and most other X500-series tractors). According to JD Parts, AM147167 is the shock used on current X300-series tractors. It's also $78 compared to $90 for the correct one. What did the dealer charge you?

Part Number:
M808782
Part Price: 90.05 USD
Description: Shock Absorber - ABSORBER, SHOCK
 

·
Registered
Joined
·
2,058 Posts
Discussion Starter #62
Correct. M808782 is the correct shock for the X590 (and most other X500-series tractors). According to JD Parts, AM147167 is the shock used on current X300-series tractors. It's also $78 compared to $90 for the correct one. What did the dealer charge you?

Part Number:
M808782
Part Price:90.05 USD

Description:Shock Absorber - ABSORBER, SHOCK
I haven't paid anything. I've received zero paperwork as of yet. They told me that all warranty work is all kept in the system so who knows.
 

·
Registered
Joined
·
2,058 Posts
Discussion Starter #63
Got the tractor out yesterday and the original problem is still present. Reverse will hang slightly then release but then the forward pedal is very stiff and hard to press down. Contacted the dealership manager today and informed him. Here we go again.
 

·
Registered
Joined
·
2,058 Posts
Discussion Starter #65
Are you still using the wrong shock absorber?
Thanks for your replies both here and the other forum. Trying to get as much information out to hopefully figure this out, if not by Deere, but myself if I have too. The shock they installed is still installed. I don't want to touch much until I hear back from the dealership. Not holding my breath for what I think needs done but we'll wait and see. Good thing I'm getting older and more tolerable with things lol.
 
61 - 65 of 65 Posts
Top