My Tractor Forum banner

Wisconsin S-7D Motor refusing to start

20286 Views 56 Replies 10 Participants Last post by  Fcubman
I'm still scratching my head with this one. From my bush hog D4-7. Finally got it to turn over and now it's not starting. Fresh battery, new spark plug, fuel, carb cleaner, engine starting spray, nothing. It just keeps turnin and turnin.

From all of that (not being a master of engines by any means), I would assume it's not getting a spark, no spark not from lack of fuel. So the distributor maybe? No power to that?

What do you guys think? Thank you all for your time.
41 - 57 of 57 Posts
Sorry didn't mean for it to get confusing. I'll do that and post the results tomorrow after work. Thanks!
I'm not blaming anyone for my own confusion! I just had a little trouble keeping this thread straight in my mind, since I've been following a couple of others that are similar. My problem, entirely. :banghead3

I'll be watching for your results. :sorry1: if I seemed to blame anyone but myself.
lol it's alright. But before I post that, you wrote about points. What are the points?

Here's what I got:

With my switch on; my positive side of the coil reads 12.94 volts, negative reads the same.

With my condenser grounded like you can see in the photos with the blk alligator clip in post 36 last photo. The negative side of the coil is going to that, then I took an alligator clip and grounded that to the machine itself. When I did that, the positive side of the coil is 11.73V & the Neg side of the coil is 0.53 volts. Still with no spark.

I hope that makes sense?
Okay, I think I have a handle on it now….

The points are shown in pic #36, bottom photo. They are the "switch" that turns the current on and off through the coil by grounding the - side of the coil, then breaking the ground path. That silver rod that comes out of the engine case should open and close the points as the engine turns. Watch it, and you'll see how the points open and close.

The - side of the coil should attach where you have the black clip lead. The condenser appears to be connected correctly: the wire should attach to the points lead/spring, which it appears to do, and the case of the condenser is grounded through its clamp. The wire should NOT be grounded. It should go to the connection for the points, as it seems to do in the picture.

Try this: turn the engine by hand so that the points are not closed (not touching each other). Connect the black lead in pic #36 to the - side of the coil. Turn the switch on. You should have B+ at the black lead. (If you don't, let me know. That's another issue we can correct.) With an INSULATED screwdriver, short across the points a few times. You might see a small spark at the screwdriver, but you should see a spark at the plug.

We're closing in - almost there!
See less See more
I've checked the points and I've gaped them correctly with my gaping tool.

The - side of the coil is connected where the black alli clip is attached in the photo.

Will do what you said in a moment and report back.
AND YES! I got a spark!!!!!! FROM THE SPARK PLUG!

Played around down there with the flathead and boom spark.

Alright, now that that's over, what needs to be done? :)
Permanent type wiring for the coil. I'd clean all the crud out of the points box: that looks like rust, and rust will short out your circuit. Make sure the plunger moves in and out when the engine turns. You did adjust the points gap when they were held open by the plunger - right? If the points don't close - no spark. If the points are dirty and won't conduct electricity - no spark.

Try pulling the plug out of the engine (to make spinning it easier) and see if you get spark with the engine turning, either by electric starter or by hand. You should have a plug connected to the coil lead and grounded. Creating high voltage in the coil with no place for it to go can destroy a coil. That will be the final test! If you have spark while the engine turns, you have succeeded!
Well she has a spark now! I put some fuel in the carb and she didn't kick over. I'm trying to get the adjustment right now. I read for the needle at the bottom according to the manual, it's 2 full turns out. I got nothing. I noticed that if I put my hand over where the air filter should be, that the rpms go much higher and it seems like it wants to start, but just wont.

The knob for the throttle adjustment needs adjusting and the other knob for the air/fuel mixture needs adjusting I'd assume. The manual is no help as it says it was set at the factory so no further adjustments are needed. LOL yeah this isn't factory fresh ;)

Any tricks or facts anyone has will be greatly appreciated.
Try spraying some carb or brake cleaner in the intake and starting it. If it runs for a few seconds, you know the mechanics and electrics are okay.

Is the choke closing? You didn't mention that in your last post, I haven't reread the others.

Do you have adequate compression?

Have you checked to see if the flywheel key is not sheared, even partway?

I am assuming that your spark plug is in good shape, and firing.

Have you checked for spark with the engine cranking?
Tried spraying starter fluid in, didn't get much. Took the carb off and sprayed right in, I would be getting a pop, but nothing else.

Choke is closing, compression is fine, flywheel is fine. SP is brand new and firing now :)

And it's sparking with the engine cranking.
This is a puzzler…One of the three is missing -
1) spark at the right time
2) enough compression
3) proper fuel mixture

You pretty much rule out the fuel when you spray into the carb, so that leaves #1 & #2.

I'm at a loss except to suggest that you approach this engine like you've not seen it before, and recheck everything as if you hadn't worked on it at all. Assume nothing.

I do have one suggestion - recheck the points gap - if the gap is way off, you'll get spark, but the timing will be off. It's worth a shot, and easy to do.

I know how frustrating this can be. I spent all winter, on and off, trying to start an old Farmall Cub. Everything was there, but it wouldn't start beyond one pop that would kick the starter out. It turned out to be a bad condenser that would allow a weak spark at cranking speed, and no spark above that. A new condenser, and it starts great. I have never run into a weak condenser in the 50 years I've been playing with small engines. There's a first time for everything. Hang in there, you'll get it! :fing32:
See less See more
just read the whole thread....dang so close

waiting with fingers crossed :)
Well darn it. I did what you said and rechecked everything. Re-gaped everything to be sure, it sounded like it wanted to start and then I heard a pop, looked up and noticed the SP popping up, the threads are stripped! Re-tapped with an 18mm tap and still it's popping out.

Heli-coil? Anyone know the correct size so I can order it? I have a time-sert kit for my 5.4 V8 engine, too bad that wouldn't work :(

So close...and now another set back.
They make kits for just that - take your plug to an auto parts store, and they should be able to fix you up.

I do admire your tenacity!
Any news?
Yes! GOOD NEWS! IT LIVES! Blew the spark plug from the head, had it sent out and heli-coiled. Came back, installed and she started right up!

Granted the throttle and choke were all out of whack, but it's running! Photos from that eventful day...

Land vehicle Vehicle Tractor Lawn Outdoor power equipment

Lawn Vehicle All-terrain vehicle Grass Outdoor power equipment

Land vehicle Vehicle Tractor Natural environment Grass

I redid the wiring the other day to get the headlights and tail lights going again. Need to find a bulb for the tail light. I was chasing my tail trying to figure out why that wasn't turning on, come to find bulb lol.

Now working on the throttle adjustment. I also found a seat back off of a melex golf car so those two mounting bolts are shoved into my back each time the high/low switches over.

Thank you all so very much for all the help over the past **** almost year. I couldn't have done it without you.
See less See more
41 - 57 of 57 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.