My Tractor Forum banner

1 - 9 of 9 Posts

·
Wheel Horse Junkie!
Joined
·
158 Posts
Discussion Starter #1
My newest addition, a 1981 Wheel Horse E-141. Tractor is not charging at this point so I have some work to do. I will be posting questions if I start banging my head against the wall. Here it is.........



 

·
Wheel Horse Junkie!
Joined
·
158 Posts
Discussion Starter #4
Yes....it is powered by 6 12 volt batteries. No belt for the deck but an electric motor for each spindle to spin the blades. Pretty cool tractor...looking forward to working on it.
 

·
Registered
Joined
·
191 Posts
Nice find ! They didn't build a whole lot of them, so to find one in this condition is a plus !

The chargers can be kinda finicky....same with the tractor controls.

I believe I have a manual stashed away somewhere, so pm me if you need a copy.

Good luck, and keep us posted !! :D
 

·
Wheel Horse Junkie!
Joined
·
158 Posts
Discussion Starter #6
Thanks Electrak........I have a feeling that the problem is in the charger itself. I am ready to roll up my sleeves and have some fun with this one.

I have all the manuals for it, which were included in the deal. I greatly appreciate the offer though. Thanks so much!

I will let you know of the progress or lack of!
 

·
Wheel Horse Junkie!
Joined
·
158 Posts
Discussion Starter #9
Sorry guys, lost track of this post as the tractor was put on the back burner for quite a while. Finally saved up some money and purchased the 6 new batteries! Ouch.........that get's expensive!

Doing some minor touch up work........needs to have a restoration job in the future but wanted to take care of some problem areas.

Need to get the batteries hooked up as they are now on the tractor. If everything goes as planned I will be taking this with me to the Charlotte, MI tractor show on August 7th. If you are able to attend, please stop by and check it out!
 
1 - 9 of 9 Posts
Top