My Tractor Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,070 Posts
Discussion Starter #1
I have a 417-H with a row of red idiot lights that do not work. Anyone have any experience trouble shooting them? I have not as yet attempted to find the problem but have been thinking that now would be a good time to get started.
 

·
Registered
Joined
·
926 Posts
Ah yes, the idiot lights. Mine started blowing the main 25a fuse when you turn the key to the run position and after several hours of troubleshooting I found the yellow feed wire to the circuit board to be bad/corroded on the board so I yanked every wire out of the entire tractor and rewired myself. It took about 3 hrs to wire it and know it runs like it should.

I have the 314-H but it is the same lighting system I think.

It is wired like they were for 30 years before idiot lights.

one wire from fuse box to battery terminal on switch
one wire from switch to solenoid
one wire from switch to magneto for shut down
one wire from switch to accy fuse for lights
one wire for ground

hope this helps.
 

·
Registered
Joined
·
1,070 Posts
Discussion Starter #3
Well the tractor starts and runs great. There is this bank of red diode lights mounted in the dash. They have not worked since I have had the tractor. Must not be very important but I like things to work as they should. I will make this a winter project.
 

·
Moderator
Joined
·
16,631 Posts
Plse do a detailed write up, with pictures..
:thanku:
I have seen several inquaries on that series of tractor here in last year or so--

glenn
 

·
Registered
Joined
·
1,070 Posts
Discussion Starter #5
One of those inquiries might have been from me. I was hoping someone had a systematic process to troubleshoot them. Since none of them work, there must be something common to all, that prevents them from operating. Looks like the entire circuit is to warn you of safety problems. Most of the safety devices on this tractor have been disconnected by the prior owner. At some future date I intend to restore this tractor and a complete rewire to specs will be done then.

At this time it is set up to blow snow and winter is upon us and there is snow falling just 50 miles from me already. Don't think we will get much but maybe next time:thThumbsU.

As for the write-up I certainly will do just that.
 

·
Registered
Joined
·
1,752 Posts
I believe the lights on your WH are similar if not identical to the ones on my 416-H and will not come on unless it reads something is wrong.

Start with one safety switch. Try engaging the PTO and put the key to the on position. If it lights up, you know the circuit is working. If it doesnt, you have disconnected switch or circuit board.

You may be lucky and everything might just be bypassed. If thats the case, worse case scenario, you may have to hook back up the switches. Best case, replace the light circuit board.
 

·
Registered
Joined
·
1,070 Posts
Discussion Starter #7
There is a test button and when you push that nothing happens either. As I said earlier, it is not an A priority as it runs and the snow season is upon us. I was just curious to see if anyone else had a quick fix for it. Other than the lights, it runs perfectly and is very dependable.
 

·
Registered
Joined
·
1,752 Posts
There is a test button and when you push that nothing happens either. As I said earlier, it is not an A priority as it runs and the snow season is upon us. I was just curious to see if anyone else had a quick fix for it. Other than the lights, it runs perfectly and is very dependable.
Same here, only SOME of my lights never lit up until I wired the switches back up. If the test button doesnt work either, I would say your board is blown or the little wiring harness itself is shot. I am leaning toward the board going bad though.

You probably know replacing it is easy. I think there is only one little nut you have to take off and disconnect the wiring harness. May be a little bit of a pain to get those little rubber grommets and lenses over the bulbs but thats it.

Going to replace mine a little later too. That is after I get some paint on the thing and some body work this summer. Grommets are dry rotted and hard to see the top three because the lenses are gone. I wish ya luck.:thThumbsU
 
1 - 8 of 8 Posts
Top