My Tractor Forum banner

1 - 17 of 17 Posts

·
Retired Super Moderator - Deceased September 2015
Joined
·
26,679 Posts
:MTF_wel2:Glad you joined!
:wwp: If you need easy Picture help
Be sure to Register for Your State!
 

·
9K+ Poster
Joined
·
12,164 Posts
What problems are you having with which models?
 

·
Registered
Joined
·
1,176 Posts
welcome to mtf
 

·
Super Moderator
Joined
·
17,111 Posts
Welcome to the Forum:MTF_wel:
 

·
Registered
Joined
·
3,791 Posts
That's why we are here, to help so post away and enjoy the forum! :wwp:
 

·
Registered
Joined
·
441 Posts
fire the questions away.....
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #11 ·
Well i think the rear end on my L130 is going out .It runs fine till it warms up then it whines,starts slowing down ,then stop moving! once the rear end cools down i start all over agian... what do you think ???
 

·
Murray tractor owner
Joined
·
2,672 Posts
That is the most common case for the L/LA series. Are you going to do the K66 upgrade or get a different tractor. (The K66 is over 1K but ask stadril to be sure.)
 

·
9K+ Poster
Joined
·
12,164 Posts
Well i think the rear end on my L130 is going out .It runs fine till it warms up then it whines,starts slowing down ,then stop moving! once the rear end cools down i start all over agian... what do you think ???
I would start by draining the tranny fluid and replacing it. There are several posts here on how to do it. That may get you going for the cost of the fluid; otherwise you may be looking at bigger costs.
 

·
Former MTF Admin.
Joined
·
25,773 Posts
Welcome Tjordan, yep classic symptoms you're describing on the L130 behavior of either needing a fluid change or some internal parts replaced, best wishes and let us know what you decide to do on it :).
 
1 - 17 of 17 Posts
Top