My Tractor Forum banner

1 - 6 of 6 Posts

·
Gravely bug bit.
Joined
·
8,735 Posts
Discussion Starter · #1 ·
Been there for 3 weeks now. It has a failing pump or control valve on the leftside pump/motor setup. So I'm using a Pro Turn Commercial 260 XDZ for a while. 31 HP Kawi engine. :D
 

·
I Love All Color Tractors
Joined
·
22,321 Posts
Is this becoming a common failure or just a fluke?
 

·
Gravely bug bit.
Joined
·
8,735 Posts
Discussion Starter · #3 ·
Is this becoming a common failure or just a fluke?
This is thje second mower that we've had in the shop out of 4 we sold that suffered a pump failure so it is beginning to look like it might be a common problem. Both were left side ones so that tends to say there is something wrong.
 

·
Premium Member
Joined
·
2,732 Posts
I try to stay up on information about these machines Don, in case I end up with a 10 acre lawn. This news is a bit disconcerting - I hope they get the problem corrected.
 

·
Gravely bug bit.
Joined
·
8,735 Posts
Discussion Starter · #5 ·
I try to stay up on information about these machines Don, in case I end up with a 10 acre lawn. This news is a bit disconcerting - I hope they get the problem corrected.
I expect them to drop them in the next year or two. Or change the drive system to the Pro Turn style.Right now the only new ones you can buy have the 30 HP Kohler.
 

·
I Love All Color Tractors
Joined
·
22,321 Posts
It does certainly appear to be a common problem in the making.

Do the right and left sides use a different drive system? If not, I cannot think of a reason for the left to fail and not the right.
 
1 - 6 of 6 Posts
Top