My Tractor Forum banner

61 - 68 of 68 Posts

·
Make Better Mowers
Joined
·
2,010 Posts
Did you check the ground wire at the frame?
 

·
Registered
Joined
·
454 Posts
Still waiting??
 

·
Registered
Joined
·
121 Posts
Discussion Starter #64
Update:

sorry guys I didn’t get any alerts that there was more posts.

so just today I called to find out as it’s been two weeks in the shop. I didn’t get to speak to the guy that worked on it but he pulled the slip but didn’t have first hand knowledge of it

pretty much he said everything checked out perfect with the issue being the transmission PTO switch. He didn’t really make much sense other than what I believe the cause was inadequate wiring of the transmission PTO switch such that there was inadequate space in the 3PH arm area.

perhaps the wiring was rubbing against the 3PH arms when it hit the bump

it’s still under warranty, only 80 hours on it so I’m hoping the dealer does what it can for me in terms of warranty because a few people have reported inadequate routing or spacing of the wiring harness in this area
 

·
Registered
Joined
·
121 Posts
Discussion Starter #65
Ps he also read out that absolutely every thing else checked out ok, the console cluster, all the safety switches the battery etc....

Can’t wait to get it back cos I bought a 60HD broom also and could really use it for this slush right now
 

·
Registered
Joined
·
598 Posts
Glad to hear tractor is fixed and ...soon... on it's way back. Smart move having dealer fix it too. I'm thinking you might still be looking for that one small spot of insulation that got pinched/worn off! Have fun and go play in the snow... err, slush! Bob
 

·
Premium Member
Joined
·
6,170 Posts
I just looked at the wires that go to the PTO on my X720, Wow, These could rub thru the vinyl pretty easy, I'll have to get these wires shielded before grass season.
 

·
Registered
Joined
·
949 Posts
Well, did they actually fix it? Is it back? Was is the PTO wiring that got pinched?
 
61 - 68 of 68 Posts
Top