My Tractor Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a TS110 that after running for about 4 hours, it starts to run rough like it's getting too much fuel. The exhaust is white/blue and is really a heavy diesel exhaust smell. I haven't checked the fuel filter for water yet, but I had added some Cetane booster additive to the fuel for Ford Powerstoke engines. Is this causing my problem or do I potentially have water in the fuel? I use off road diesel and I'm in KS so it's hot now! I'm really hoping this isn't a fuel pump or injector problem. Thanks much!
 

·
Cal Fire Air Tanker Pilot
Joined
·
143 Posts
white/blue is water in the fuel MAYBE, Or a blown head gasget, What temp is (water) the tractor when this happens? is the radiator making popping or gurgling sounds? Water temp looks normal or below normal if there is no water in it or it's almost gone.

Is the Air cleaner clean? No Obstructions?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for the response. I've had a couple of days to do some things. First, I replaced the fuel filter last night, but didn't see much in the filter. It appears no water, but some dirt sediment. Second, and this may be my problem overall, I started using a cetane booster, whtch I THINK, if I recall, the problem started after that. ARGH!!! After talking to a heavy equipment mechanic tonight, I may have had poor performing or bad diesel additive. He told me I normally shouldn't need anything except in the winter. I just need to add some more fuel and try it again. I added 10 gallons of fuel and additive last night and baled today for about 5 hrs, and sure enough, it started acting up again. Finally, the water temp is normal, radiator is full and the air filter is clean. I cleaned it out last night, but it had little dirt on it. Thanks again.
 
1 - 3 of 3 Posts
Top