My Tractor Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I was having issues toward the end of last year with my battery staying charged. I have been troubleshooting the issue and wanted to run this by you all:

The battery reads 12.5VDC when tractor is off.
The battery reads 12.5VDC when tractor is on at wide open throttle.
The voltage across the stator leads reads 41VAC at wide open throttle. The K341 manual says if the voltage is 28VAC or more the stator is OK, so my assumption is, it's ok.

Bought a new regulator / rectifier today and the voltage coming out of the B+ lead was 0.27VDC at wide open throttle down to ~0.19VDC near idle. Are these the correct values?

The issue is, the battery is showing 12.5VDC at wide open throttle, and I assumed it should be showing around 14VDC. What else could be the issue? Do you all agree the stator is ok?

Thanks
 

·
Registered
Joined
·
70 Posts
Read the resistance across the leads from the stator, you should read less than .5 ohm resistance.
If you read infinity ohms, the stator coil is open and the stator is defective.

steve
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
Read the resistance across the leads from the stator, you should read less than .5 ohm resistance.
If you read infinity ohms, the stator coil is open and the stator is defective.

steve
It was reading ~0.5-0.6 ohms using my not so top of the line meter. I believe the stator is good. Will dig further into it tonight.
 
1 - 3 of 3 Posts
Top