My Tractor Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
The battery on my TC26DA went dead. I put the charger on the battery and after a short time tried to start it. The starter solenoid clicked a few times and then went silent. I let the battery fully charge and then tried again. Now I see no action at all from the starter. When I turn the key on, all the dash gauges activate as normal, but nothing goes beyond that. No cranking of the starter, no clicking of the solenoid and significantly I think, the glow plug light does not illuminate with the switch in the glow plug position. Park brake is set, transmission and PTO levers are where they should be. Everything is exactly where it was the first time when I tried to start it and the solenoid clicked, but now no clicking from the solenoid. I've tried wiggling the trans and PTO levers, that made no difference. I did see an online reference to a New Holland sticking solenoid issue but couldn't link to the message. Any thoughts of where to start looking for a fix? TIA, Lee
 

·
Mountain Mike
Joined
·
131 Posts
Even though the transmission lever is in neutral there is a chance that the micro switch isn't being made (switched on). Try putting the lever in neutral then reach in there and manipulate the switch to see if you hear it click. If it does you know that is the culprit. This happens to me frequently. I will wedge a handkerchief or paper towel between the cam and the switch, crank the engine, remove the wedge, then go on about my business. I call it a theft deterrent but others may say I'm too lazy to fix it. The switch is in a very awkward position and adjusting it requires a bit of contortion to get in there.
 

·
Premium Member
Joined
·
5,483 Posts
Test the battery voltage, to see if it's 12.6V. If the battery is dead, depeding on the charger and the mode it's set at, it can take quite some time to charge it back up.
 
1 - 3 of 3 Posts
Top