My Tractor Forum banner

1 - 4 of 4 Posts

·
John Deere STX30
Joined
·
35 Posts
Discussion Starter #1
I have a '91 STX30 that emits exhaust smoke for about 10 secs at start-up, and then no smoke thereafter. Is this an issue or most likely a little too much oil that is being burned off? It seems to run strong (1st start-up in over a year) after that. It does have a slight miss while running. Thanks for any advice!
 

·
Registered
Joined
·
3,953 Posts
RU using a choke to start it?

If yes, hold the choke for the first few revolutions of the motor or until the first KICK then release, don't hold it full choke all they way until it starts - and you will cut the smoking by 90%...

if it is missing, a carb cleaning is in order. and if doing a carb clean might as well check the whole fuel system from the in-tank pickups, fuel lines and filter...


.
 

·
MTF Tractor Nut
Joined
·
4,432 Posts
If it's only on start up and you don't notice a change in oil level, then why mess with it? I guess it could be annoying if you're starting it inside... Sounds like a carb cleaning or Sea Foam treatment might help with the missing.
 

·
John Deere STX30
Joined
·
35 Posts
Discussion Starter #4
RU using a choke to start it?

If yes, hold the choke for the first few revolutions of the motor or until the first KICK then release, don't hold it full choke all they way until it starts - and you will cut the smoking by 90%...

if it is missing, a carb cleaning is in order. and if doing a carb clean might as well check the whole fuel system from the in-tank pickups, fuel lines and filter...


.
Thanks for the advice! I'll give it a try!
 
1 - 4 of 4 Posts
Top