My Tractor Forum banner
1 - 1 of 1 Posts

· Super Moderator and over 6K Posts!
6,791 Posts
Discussion Starter · #1 ·
Hi guys! Wasn't sure where to post this but since we all mow we probably all trim at some point. I wanted to share something that I ran into today in case someone else has a similar problem. I have a Ryobi 790R power head with the removable attachments, the one in particular is a straight shaft line trimmer. I got the line trimmer as part of a package deal with the trimmer but it has only been used once or twice by me since I got it. The problem was that the line would not advance when the bump head was tapped on the ground. I have used this style of bump head on my curved shaft attachments for many years so I am aware of how to wind the spool and advance the line. After using it again today the line would still not advance so I decided to try to find out why. I disassembled the head, removed the line and the bump spring and tried to manually work the advance and it was okay. I reinstalled the spring and bump knob but it would now not advance. After some careful consideration and measuring I determined that the bump knob was not letting the spool come up far enough after bumping to advance. I ended up making a custom washer for a spacer so the bump knob wouldn't go on as far but would still tighten up. This was all the difference it needed to work properly. I had purchased the bump knob after I had the trimmer as the spool and bump knob were missing and they had an aftermarket string head on the trimmer but all the parts were replaced with factory parts. Just thought I would pass this along in case anyone else had run into this problem. Bill
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.