My Tractor Forum banner

Starter troubles

624 Views 1 Reply 2 Participants Last post by  tomw0
Hello MTF,
I need a little figuring out my starter issue. Short story..... bought used Branso 4220 with cracked head. Replaced with new head - replaced oil - replaced hydro oil - replaced all filters etc installed new battery and checked all cables.

Turned the key and nothing. Poked around and saw a couple of jumped out terminals close to the starter. I’m assuming previous guy jumped out safeties. Still poking I find a push button under the dash..... well I pushed it and bingo motor turning. Got a little excited and cranked way too long and starter got real hot and nothing after that!!!!

Took starter off filed contacts flat cleaned all crud off everything. Put it back together and bench tested ?? back in business. Installed and nothing not even a click. I have 12v going to starter and up to the push button. However when I push the button nothing???? What the heck?? Checked the button and I have 12 coming in but not out. Removed solenoid trigger wire and tested again.... I have 12 still coming in and now coming out through the button, so button is good.

Now I’m thinking poor ground right? I placed negative jumper directly from the battery to the bolt holding the starter. All I get is a weak click, not like a solenoid click more of a tick than a click.

Take it off again using jumper cables from battery and using the button.... bingo works great!!! No hesitation no ramp up all appears to good with the starter. I should mention I turned the motor by hand thinking the worst, but it turns over just fine.

What the heck am I missing here? Does anyone have any suggestion or ran into this before? Any help would be greatly appreciated.

Thanks in advance
See less See more
1 - 1 of 2 Posts
1 - 1 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top