My Tractor Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
552 Posts
Discussion Starter #1
Put a new float in the carb and she fired right up and ran great! Put on the air cleaner and drove around the house and it started loading up and dying again.:-(

Could a bad intake gasket cause the same symptoms?I replaced both gaskets and thought one looked terrible when i pulled the intake. I thought the float was the issue but it looks like it may be something else.Any thoughts? Suggestions?
Thanks Moto
 

·
Registered
Joined
·
552 Posts
Discussion Starter #2 (Edited)
It looks like i have two fuel pumps on this tractor for some reason.Is there supposed to be two? PO may have added a new one and plumbed it in without bypassing the old one? not really sure how this is supposed to look but i will post a pic of mine in a few minutes
 

·
Deere 330 Killer
Joined
·
17,892 Posts
The only one you should have is the second one, right pic, attached to the carb.
 

·
Deere 330 Killer
Joined
·
17,892 Posts
Just take the pump apart and put some 3 in 1 oil on the gaskets, seals it up and pumps real good
 

·
Cranky Motorsports
Joined
·
15,270 Posts
What Hugh said-BUT make sure your tank and fuel lines and filter are clean too- my 18/6 had so much gunk in the tank that it would start and run for about half a lap in the yard then the crud would clog up the filter and it would die from no fuel- by the time I would open the hood, the gunk would flow back to the tank and it would crank up and run for a lap again... Took quite a few times before I caught the crud in the filter before she quit. cleaned the tank, new filter, and problem solved.

beside the fact, that "T" may be leaking vacuum, and it looks like the fuel line going into the mikuni pump is WAY too small- should be 1/4 from tank to carb.
 

·
Registered
Joined
·
6,227 Posts
I agree with what the guys said but would add....you could try this..

You don't have to by pass the old fuel pump. Get rid of the tee, plug the vac on the old pump with a piece of hose and a screw or something. The fuel will just flow threw the old pump. Now the vac is only running the other pump. I'm not sure there is enough vac to run 2 pumps anyhow.

Becarful the plastic nipples on the old pump break off easy.
 

·
Registered
Joined
·
552 Posts
Discussion Starter #10
Bypassed mikuni pump and lubed up the factory pump.Has great suction at hose and seems to be moving fuel.Checked float again,seems to be fine.Going to swap out line for 1/4 inch and check filter again.My tank looks amazingly clean inside.I truly appreciate all the help you guys give. Thanks
Moto
 

·
Registered
Joined
·
378 Posts
Its also possible the float is not set right.
 

·
Registered
Joined
·
552 Posts
Discussion Starter #12
It was the float! I apparently went the wrong way with it when i first installed it.Put a fairly heavy tweak on it the other way, at least a 1/16 th adjustment past stock setting and she runs perfect!So heres the tally before i figured it out.

1. coil
2.fuel pump
3.carb
4.fuel lines to small
5.removed secondary impulse pump and t
6.float ding ding ding ding !!!!!! winner !!!!!
I have a brand new still in package float for an onan if anyone needs one.Didnt think my transaction went through and bought two!
Also have an extra used brass float i would give away if you want to pay for shipping.
Thanks for all your help my friends! Couldnt have done it without you.
 

·
That there's worth fixin'
Joined
·
1,892 Posts
glad you got it working. I used my ss16 a lot today. It's been trouble free for a year since I changed the old float to brass.
 

·
Deere 330 Killer
Joined
·
17,892 Posts
Glad you got it worked out! Unfortunately, the brass float in mine isnt gonna stop it from needing a rebuild sooner than later :(
 

·
Registered
Joined
·
552 Posts
Discussion Starter #15
Now i need to do the st16.Going to pull the tank and run new fuel line and filter and clean carb and fuel pump.Also will need a battery :-(
 

·
Registered
Joined
·
552 Posts
Discussion Starter #18
Thats for sure smallfry! Im starting to get used to a clutch." no more wheelies "
My other tractors were mostly hydro.
 

·
Registered
Joined
·
552 Posts
Discussion Starter #20
I am really suprised with the difference in power from my 12 hp k301 to this onan 16. Its got massive torque.I put the dozer blade on it and pushed a leaf pile into the woods and the blade dug in and took about 4 inches of dirt with the leaves oops
 
1 - 20 of 30 Posts
Top