My Tractor Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #1
My OEM Stihl trimmer head, I’m guessing, is kaput. The pop on/off cover will no longer stay on after respooling the head. I just found out about the Speed Feed heads. Is this the way to go? Any recommendations? After a short search, I found this one: Stens 385-288 Speed Feed 450 Trimmer Head https://www.amazon.com/dp/B008G4GMOU/ref=cm_sw_r_cp_api_o7YCBbWHD4PJ8




Sent from my iPhone using Tapatalk
 

·
Moderator
Joined
·
16,355 Posts
Bump up!!
To the OP--I can't help with ur question, but this will bring it back to top.
Stens does make some good replaceable parts that I have bought from time to time-

Good luck--

glenn
 

·
Registered
Joined
·
1,661 Posts
I installed an Oregon Speed Feed on my Echo after the original grenaded and I couldn't source replacement parts locally. I was very happy with it, easy to load and it worked flawlessly. I did have to cut a notch in the debris shield so I could see the arrow to line it up with the eyelet.
 

·
Registered
Joined
·
154 Posts
Discussion Starter #5
I’m wondering why mine didn’t go back together? I ran out of line, took it apart, respooled the line, and the cover wouldn’t stay back on.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
233 Posts
My OEM Stihl trimmer head, I’m guessing, is kaput. The pop on/off cover will no longer stay on after respooling the head. I just found out about the Speed Feed heads. Is this the way to go? Any recommendations? After a short search, I found this one: Stens 385-288 Speed Feed 450 Trimmer Head https://www.amazon.com/dp/B008G4GMOU/ref=cm_sw_r_cp_api_o7YCBbWHD4PJ8




Sent from my iPhone using Tapatalk
I have this SpeedFeed head on my Stihl and it works good and is easy to fill. I'm happy with it.

Sent from my SM-G960U using Tapatalk
 

·
Registered
Joined
·
1,091 Posts
i've never. The way i look at it, by the time the cover is worn thru, the rest is probably getting close to worn out also. I've never physically broken any of mine as in cracked a piece or a lug off, mine wear out from the rocks and ground contact...........Mike
 

·
Registered
Joined
·
154 Posts
Discussion Starter #12 (Edited)
Do I go w/ the 375 or 450? Or a non speed feed head like the T-35?
My head is spinning almost as fast as a trimmer head, researching all of these head designs.

Also, I do most of my trimming on concrete. Which line size/type do I use?


https://rover.ebay.com/rover/0/0/0?mpre=https://www.ebay.com/ulk/itm/371576629115

https://rover.ebay.com/rover/0/0/0?mpre=https://www.ebay.com/ulk/itm/123265270521

Husqvarna 537388101 Universal T35 Tap Advance Straight Shaft String Trimmer Head Prewound With .095-Inch Line https://www.amazon.com/dp/B000AM2IK8/ref=cm_sw_r_cp_api_qr1DBbD47A9H2

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,078 Posts
Or this? Echo 99944200907 Speed-Feed 400 Universal Trimmer Head https://www.amazon.com/dp/B00G5KL0QW/ref=cm_sw_r_cp_api_Er2DBbRWQQEZD

I’m kind of leaning towards the Echo.


Sent from my iPhone using Tapatalk
That's the kit I installed on my fs94r. Very good setup and easy to follow directions. I wasn't impressed with the included pre installed echo trimmer line so I swapped it out. But other than that I've been sold on it. Zero issues as of yet.

https://www.mytractorforum.com/index.php?page=active_topics#/topics/1284001
 

·
Registered
Joined
·
404 Posts
I bought a speed feed head for my echo trimmer. The instructions were a little confusing, but once someone showed me how to do it, it was amazing. Takes maybe 30 seconds to restring without taking anything apart. I can't see myself ever using anything else
 

·
Registered
Joined
·
154 Posts
Discussion Starter #18
I finally received the Speed Feed 400 and installed it. Trying to save a buck, I purchased it from eBay from a seller that appeared to be buying Universal kits and splitting them up to sell w/ bulk purchased SF heads. This way they could sell you what you need for a little less than buying a Universal kit with some parts that’s you don’t need. Well, there was some miscommunication and I didn’t receive what I needed. I tried to explain the arbor I needed was green, but I received gold. Anyhow, we got it straight and I’m a satisfied customer.

I’ve only used it once, and it doesn’t take much of a bump (ON GRASS) to feed the line.

Thanks for your replies/help!


Sent from my iPhone using Tapatalk
 
1 - 19 of 19 Posts
Top