My Tractor Forum banner

Snapper Pro S150X Not Charging...

765 Views 6 Replies 1 Participant Last post by  Sephiroth
I bought this mower used and it worked fine for a few years, but now I have an ODD problem. The battery is not charging. Testing voltage from the battery wire connected to the negative battery terminal or any ground shows negative voltage! Yes, red probe on the regulator terminal and black to negative battery or ground. At idle I read -4v DC and at half throttle I get -10v DC. Half throttle produces about 30v AC at the two wires from the stator/coils/etc.

I bought a brand-new rectifier/regulator and it does the same thing. Testing was done with the wires connected. The battery terminal on the regulator is wired to the positive post on the starter solenoid, which is connected via the thick cable to the battery positive terminal.

Engine is a Kawasaki FH641V, 21HP. What is going on here?
1 - 7 of 7 Posts
Apparently I am not the only one with this issue. The thing is, nobody every produces a solution. The threads just die.

Also note that this unit (FH641V-ES25) has both an alternator AND magnetos. There are two coils with pick-ups outside the flywheel. These serve only to power the plugs. INSIDE the flywheel there is a rung of what appear to be wound copper coils, all the way around. This goes to the stator. Again, output from stator is 30v DC, which manual shows is correct.
I'm guessing I am unique in this very odd situation. Can anybody even give me an idea of where to look? I have checked my wiring harness and all seems good. No corrosion, loose connections, etc. Only thing I noticed is a connector above my oil filter with no wire on it. I am assuming that is an oil-level shut-off or oil-pressure shut-off, but I check the oil each morning and it never burns any.
OK, I had some time this afternoon so I went outside and unbolted the control assembly from the right fuel-tank. Checked all connections. All are good. Found out I had an auxiliary connection under there, waiting to be wired to a switch. Anyway I tested the circuit. I did so by disconnecting the red wire from the rectifier/regulator and placing one lead from my multimeter into the wire connector. I then placed the other lead on the battery positive post. With the switch in OFF, there is no continuity, as it should be. Turning the key to ON (run), I had 2.8~3.0 Ohms of resistance, but one of the leads may have been loose. In the cranking (start) position, there is no continuity, as the manual says. This tells me that the system is wired correctly and all appears to be good as far as the circuit from the rectifier/regulator which goes to the fuse box, then the ignition switch, and then the battery positive post.

Next I checked the AC voltage on the two leads which go into the rectifier/regulator. With the engine idling I had 16.5v AC. At wide-open throttle (mowing setting) I had 33v AC. Half-throttle was 30v AC. The service manual says it should output 30v AC at half and up to 36v AC wide-open. I meet those specs, so I do not believe there is an issue there either.

The thing is, the battery was reading 12.6v DC at idle and wide-open throttle, so something is not right. I should be at around 13.8v DC, but I'm not. Bear in mind that my plugs each have a coil on the outside of this flywheel. The magnet comes past and fires the plugs at the right time, unless you manage to sheer the key and the flywheel is off. In other words, once the engine is started, the battery and rectifier/regulator is only being used to control the electro-magnet which engages the blades. I have no lights on this mower or anything else. The battery starts the mower via the starter and that is it. The problem is that without charging, I can get done cutting a yard, load it up, go tot he next spot, and the starter won't spin due to a dead battery.

To summarize:
  1. AC voltage into the rectifier/regulator is within Kawasaki spec
  2. DC voltage out of the rectifier/regulator is always negative when measured with the red multimeter lead on the output wire and the black lead on any ground on the mower
  3. Voltage between rectifier/regulator and grounds (or battery negative) at idle is -4.66v DC
  4. Voltage between rectifier/regulator and battery positive at idle is -17.8v DC
  5. The wiring harness is in-tact and has no corrosion int he connectors
  6. The wiring harness, ignition switch, and fuse box are all good
  7. The battery does not charge
  8. I paid nearly $60 for a new rectifier/regulator (Kawasaki brand) and it does the same thing with identical readings
So I am stumped now. I have no idea what to do. I cannot afford to buy a truckload of rectifier/regulators under the assumption that my new one is also bad. My final test will be to visit my father and use his multimeter to test the diodes in the two rectifier/regulators. If those are good I do not know what to do.
I made a video showing off the problem.

Video of negative voltage
I went out on a limb and, even with the wiring harness connected, decided to run a jumper-wire from the rectifier/regulator output to the battery positive post. That resulted in 13.23v at idle and up to 14.3volts at wide-open-throttle. Apparently the three ohms of resistance in the loop from the output, through the fuse box, through the ignition, and back to the battery is too much to kick the regulator off. I just need to find out where that resistance is now.

Video of test and solution
I fixed it. It turns out that when one of my hydraulic lines began leaking it coated a connector in oil. Dirt built up and that was that. Cleaning it removed the resistance and it charges fine now.

Videos of the problem, identification of the issue, and resolution
  • Like
Reactions: dave_r
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.