My Tractor Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi Folks. Still working on my 2005 slt 1554. I've replaced the Hydro Control Assembly. I've noticed that the attach point for the Hydro Control Rod (that goes to the transmission) has two holes. It was attached to the lower one. If attached to the upper one it would move further with the rotation of the control assembly. Would this make the tractor go faster, and if so, would it damage the transmission. I've lost forward speed the last year and hope this could help speed things up.http://www.mytractorforum.com/images/smilies/thanku.gif
 

·
Murray tractor owner
Joined
·
2,672 Posts
A worn drive belt causes it to slow down. Try replacing that if you have not done it. :fing32:
 

·
Registered
Joined
·
89 Posts
The 1554 is really slow but to mow well it needs to go slow with the 54" deck. unless your mowing every day then 10mph would be nice. Mine is crawling at about 4mph at most. I don't know if the mod will hurt the tranny but i'd be interested in knowing if it works for you. I also have an 05 slt1554, great machine comfy but dammmmmmmmmm slow.
 

·
Registered
Joined
·
197 Posts
I adjusted the linkage on my 1045 and made it much faster in forward, but slower in reverse. I tried the upper hole in the pedal linkage, but I was acared it would damage the valve or would make the throw too small to easily control the tractor. I am considering drilling a new hole in the pedal to maximize both forward and reverse.
 

·
Registered
Joined
·
268 Posts
How far forward are you pressing the pedal? I found out that I was not pressing down far enough because of my work shoes so I bolted a 2x4 to the pedal and that 1 1/2 gives me a faster speed.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
Thanks Gene: The forward pedal is pressed all the way to the floor. The drive belt is new and not worn. I'm seriously thinking about moving the drive rod to the upper hole and see what kind of speed that gives me.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
Guys: Just to let you know what I finally decided to do> I tried the Hydro Control Rod in the upper hole, and had good speed forward. Smooth in acceleration and slowing down. However, it wouldn't go into reverse, and I didn't feel like bending the rod to accommodate the change. I finally unscrewed the Control Rod, as MCasey advised, and have good forward speed, but slow in reverse. That works for me as the yard has few tight corners and a lot of stright ahead mowing.

Thanks for all the input - If anyone comes up with a good fix to improve speed in all ranges, I'd love to know....:thanku:
 
1 - 8 of 8 Posts
Top