My Tractor Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all,

A few months ago I bought a LS-70 Prime-Mover (kinda bobcat) with an Onan P218G engine running on LPG. The only problem was that when you start the engine and switch the handle to control the steering, the engine stopped. First I thought the hydraulic oil system was blocked but this was not the issue. By searching on the internet I found this forum! Here I found that when you have low compression in one of the two cilinders, you have power loss. After a compression check, one cilinder had 0 pressure. Thus my engine was running on only one cilinder! The problem was a loose seat on the intake valve. A common problem with the P218G engine. After ordering and installing the new parts my compression is fine again. But now the engine won't start ...

This problem occured when I was searching for the issue of power loss. I had switched the two spark plug cables. But I don't think this could any harm? Am I right?

So I already checked the following things:
- Resistance ignition coil: 4ohm primary side/ 20kohm secundary side
- Ignition moduel: voltage go from 1V to 12V at rotation of the flywheel
- LPG tank is full
- Spark plugs Sparks but I don't know of it is enough.


I think that one of the following can be the problem:
1. With testing I didn't use the air filter. Or the LPG carburator is contaminated or I get to much air
2. A broken condensor connected on the + side of the ignition coil. But I read that this don't have influence on the ignition.
3. The ignition rotor may be loose. Hereby I have maybe a timing problem with the iginition.
4. Broken iginition module. But my test would say not.

But because I have nog explosion in the cilinders I think it would be problem 1 or 3.

Does someone have more things to check that can cause my problem?


Thanks!
Jelle
 

·
Administrator
Joined
·
17,188 Posts
Have you checked the vaporizer? My son's forklift was getting hard to start, then wouldn't start at all. He had rebuild the vaporizer bout 10 months ago so we didn't think that was prob but we were wrong. After talking w/ forklift mechanic we ended up replacing with a new unit ($90) it started like it was a new machine. Taking the old one apart there was a lot of crud and one bad diaphragm inside. We'll prob rebuild and have a spare. Since it's needed for his truck accessory biz, better to have spare on hand rather then not being able to having to find one in stock.
MikeC
 

·
Registered
Joined
·
514 Posts
if you have points ignition the condensor belongs on the negative post unless its a positive ground or using a electronic ignition unit .
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I've got an electronic iginition and have test it yesterday by removing the flywheel. It works perfect. But the LPG carburator has a broken air valve. I think the air/lpg ratio is not good. Too much air and too little gas. Now I am looking for a spare part. If this doesn't solve the problem, I wil check the vaporizer. But I can smell the gas in the carburator if I try to start. So, I think this would work fine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
After long waiting I received the spare part for the carburator. But after installing it, the motor still don't start.
We think it is the ignition coil.
Before we try to start the engine we have good sparks on the spark plugs. But afterwards we get no sparks at all! A few minutes later we have weak sparks again.
The primary side is now 10ohm and the secondary side 20000ohm.

Can anyone help me with this problem. I don't know it anymore ...


Thanks,
Jelle
 
1 - 5 of 5 Posts
Top