My Tractor Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hello my name Is Birge, I used to be a member here, not sure but haven't been on in some time, I used to have a Case Ingersoll 3010, I'm from Union MO just west of St. Louis.

I recently acquired a Simplicity Broadmoor 16 hydro, this mower has the Vanguard 16 HP V Twin motor. The precious owner said it needed a throttle cable. I have found the actual cable is fine, what does not make any sense to me is that the throttle cable when attached to the governor assembly (ie the dial that's connected to the governor arm) makes the throttle linkage go opposite direction of what it should. For example when I push the throttle lever on the dash to rabbit it throttles down, when I throttle down it actually opens up the carb. I have looked a t many things here, not sure that someone didn't monkey with it prior to me getting it, i was wondering if someone had a Vanguard 16 HP V Twin with the air cleaner off and they could shoot me some pictures of this, the governor arm, the spring attachment ect.
2440438
2440439
2440437
 

·
Premium Member
Joined
·
2,836 Posts
For my Husqvarna 52" hydro walkbehind mower, it needed a new throttle cable, and I just bought a generic one, The Kawasaki engine had two spots where the cable could be connected to (naturally, I picked the wrong one first), so in one spot, the control worked in reverse (like you describe yours works now), and using the other spot, it works properly (matching the sticker on the handlebars).

You might also try finding an image of the OEM throttle cable part on the internet and comparing it with the one on your tractor, as it may have been replaced with a generic one...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Your Correct in that there are two places it can attach but all the manuals show it connected where it is. Thanks for your help, I will double check.
 
1 - 3 of 3 Posts
Top