My Tractor Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My neighbor rolled his riding mower out of his shed after 3 years. UGLY!!! It is a Power Pro P.O.S. 12 hp B&S with a Walbro carb Among other things the carb was a mess. Cleaned it , put it back on the mower and it started right up. and I had no throttle control. All linkage in place , springs etc.. adjusted the jet out 1 1/2 ,( the way I found it ) throttle plate is closed, and the gov rod has tension pushing it closed. Am I missing something or is my neighbor buying a new carb? Does anybody out there have any ideas. Please help.
 

·
Certified Technician
Joined
·
8,420 Posts
are you 100% sure the butterfly is still attached? They sometimes come off....
 

·
Registered
Joined
·
4,043 Posts
a friend recently has one of the two throttle plate bolts come out and plate looked closed but was sideways a bit so was enough mixture flow so ran fast only.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I pulled the carb back off, throttle plate is fine, rechecked float, all good, only thing a little odd was carb manifold bolts didn't seem as tight as I installed them,new gasket may have compressed a little but I'm haveing a hard time believing that would cuase a runaway like this , never seen this situation before! I'm truly stumped.
 

·
Certified Technician
Joined
·
8,420 Posts
Well, the only way an engine can run away is if there is more air/fuel getting in.

Have you tried to back off the base idle screw?
 
1 - 5 of 5 Posts
Top