My Tractor Forum banner

1 - 14 of 14 Posts

·
Frame Swapped '88 322
Joined
·
1,236 Posts
I believe that is the oil light.
 

·
Registered
Joined
·
233 Posts
Discussion Starter #3
I believe that is the oil light.
The owners manual shows the the red light in the center of the IPC between the PTO lights as the oil pressure light.
This looks like an engine symbol with an electrical symbol in the center.
 

·
MTF mile high club member
Joined
·
5,919 Posts
Roger is correct. The reason it looks like that is it's used for the glow plug indicator on the diesels and it's a universal dash cluster. :fing32:
 

·
Bikes/Tractors what else
Joined
·
1,461 Posts
On my tractor it goes off when the fuel system is pressurized.
 

·
Premium Member
Joined
·
281 Posts
the red light electric looking coil, is infact the glow plug light. On my x740 diesel after you turn the key to "On" you wait until the glow plug light goes out before you crank. Basically tells you when the glowplug is hot enough to fire.
 

·
Diesels are awesome!
Joined
·
4,449 Posts
the red light electric looking coil, is infact the glow plug light. On my x740 diesel after you turn the key to "On" you wait until the glow plug light goes out before you crank. Basically tells you when the glowplug is hot enough to fire.
:ditto: The upside down lightbulb shape with the spring inside is the glow plug light. It should go off after the tractor is started and the plugs are warmed.
 

·
Registered
Joined
·
110 Posts
reviving an old thread.

This light came on today with my X485 nothing in my owners manual so I searched here.

The PDF in this thread lists it as either the glow plug light or the EFI light.

The tractor started and ran fine, tank was full and has had a full tuneup within the last 10 hours.

Should I ignore for a time or is this a potential issue?
 

·
Registered
Joined
·
110 Posts
Sorry thought the thread identified it. The picture in the first post. The red warning light directly above the service light, looks like an upside down light bulb with a filament in it. Identified as "C"

It has never come on before and I will have to look closely at it to see if it is blinking a code. Thank you for posting that chart.
 

·
Shacker
Joined
·
742 Posts
Had that light come on sporadically on my X485 too. After reading multiple threads about that light, I never worried about it. (I think you will find more threads on here if you search hard enough.) It seemed it would come on if it was damp/humid out, or after I blew snow and snow got under the hood. Never effected the performance of the tractor. Sometimes all I had to do, was turn the tractor off, and then restart. The light would turn off.
 

·
Registered
Joined
·
553 Posts
That seems to be the "EFI" light, which should blink on startup if there are codes, or possibly stay on if some other trouble. (see PDF in my previous post).
 
1 - 14 of 14 Posts
Top