My Tractor Forum banner
  • Are you passionate about Tractors? Would you like to write about topics that interest you and get paid for it? Read all about it here!
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,
Looking for any info or advice. I recently bought a Massey 383, I believe it’s a 1993. Was a private sale and when I tested PTO it was little hesitant, but engages every time.(uncoupled) I have it at home now and wanted to hook to my brush mower. It couples up fine, however I go to engage PTO and nothing but a grind. Will not engage. It does briefly turn mower(which is free wheeling, no obstruction) I can uncouple again and PTO will easily engage and spin uncoupled. Does anyone know what the issue may be???
 

·
Super Moderator
Joined
·
12,066 Posts
Is that a mechanical PTO ( non electric)?...Is the tractor shifitng in to its gears easily...or do you have to baby it in to avoid grinding?....Sounds possibly as though you may need a clutch adjustment....also check the gearbox for enough gear oil...and that it is not old and thin.....it may not be slowing the gears down enough to mesh the teeth
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Yes it’s a mechanical. Just a lever slide out and forward does click in. From what I read, I believe you’d be correct with the adjustment. And yeah, there is a little bit of grinding. Very brief and goes right in. I have checked the rear gearbox and fluid looks good. Pretty new. Was my understanding that the brakes were done and clutch adjustment was made in a service the previous owner had done.
 
1 - 3 of 3 Posts
Top