My Tractor Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
This tractor is new to me this winter. It had a broken clutch pedal when I got it, so I took the entire tractor apart and went through everything and cleaned it up and replaced some stuff. Did some work on the engine and changed all the fluids.
Anyways, today I hitched up the tiller that came with it, but clearly I am missing some parts. There is nothing to put tension on the belt, and the front part of its mount (under the engine) slides side to side and slips out of the ears it mounts to under the tractor frame. Anybody have a pic of a proper setup? I am planning on fabricating the missing parts so an idea of what they look like would help alot. Thx
 

Attachments

·
Registered
Joined
·
2 Posts
Resurrecting this...any update? I’ve got a 1614 and trying to attach the tiller. I too think I’m missing a hitch for the rear. The pictures provided here are helpful for the front hookup, mine has collars on the pins that would probably help the side to side motion you speak of @Idkleine.

I clicked the link above but it wasn’t entirely useful. I’m baffled with the lack of information I haven’t found on the internet. Any help appreciated, thanks.
 

·
Registered
Joined
·
2 Posts
I finally got the tiller installed, just need a belt size to buy one; I don’t have the original to compare. Anyone know offhand? I’ve googled conflicting info and my local tractor stores claim they never heard of our tractors. Was thinking to tie a string around the pulleys to gauge a length.
 
1 - 6 of 6 Posts
Top