My Tractor Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
690 Posts
Discussion Starter · #1 ·
so ole down and dirty isn't getting fuel to the carb. background: I'm almost sure this happened right after I changed the fuel filter. It ran great all the time, I changed the fuel filter (maintenance) , and it didn't work right since.

whats the diagnostic run down. i switched the filters, (thought i may have used the wrong one) and cranked it a little while, still no fuel. do i need to prime it somehow, or is that how i wrecked it to begin with when i changed it the first time?
 

·
Old Iron......Forever
Joined
·
3,139 Posts
Yea, you probably did this, but did you check the filter to see which way the arrow pointed? Could be on backwards. Honestly, I don't know how they make a filter only one way. Seems it ought to flow as good one way as the other.

Other than that, maybe the float and needle valve are stuck closed. Yea, you probably double checked that too.

KISS, keep it simple stupid! Check any of the simple things. The things you don't even think about.
 

·
Murray tractor owner
Joined
·
2,672 Posts
The fuel pump.
 

·
Junk collector
Joined
·
632 Posts
Alot of machines are gravity feed and have no fuel pump. If your is one of them, take the line off the carb and let it drain into a gas can. The fuel should come out quickly in a steady stream with no pauses or stop n' go. If it doesn't you have a blockage somewhere.
 

·
Registered
Joined
·
690 Posts
Discussion Starter · #5 ·
my tank is under the seat, so i'm assuming it has to have a pump, but i'm not sure. the line from the tank to the filter is fine. thats as far as i got. oh btw, the old fuel filter is that red small briggs filter. it does not say in or out, no indication as to which way is correct anywhere. i may try flipping it, otherwise, i haven't had anymore time, i guess i'll look at it tomorrow or so.
 

·
Banned
Joined
·
2 Posts
my tank is under the seat, so i'm assuming it has to have a pump, but i'm not sure. the line from the tank to the filter is fine. thats as far as i got. oh btw, the old fuel filter is that red small briggs filter. it does not say in or out, no indication as to which way is correct anywhere. i may try flipping it, otherwise, i haven't had anymore time, i guess i'll look at it tomorrow or so.


what motor do you have ..If you have a fuel pump ..some of them have a screw in them to bleed them ... take the line off the carb and roll it see what happens ..
 

·
Registered
Joined
·
246 Posts
Dont flip the filter, that would couse whatever is in it to come out and go into the carb. Those little briggs filters dont have a wrong way. If its a briggs twin the pump could be one unit with the carb, and have a vacuem line going to it, check that line.
 

·
Registered
Joined
·
690 Posts
Discussion Starter · #8 ·
thanks everyone, it is a briggs twin. i will check the vacuum line and all next time i get to it.
 

·
Registered
Joined
·
690 Posts
Discussion Starter · #9 ·
Well, she lives. Thanks for all the help. I checked the lines and they were fine, and filter wasn't the problem. I pulled the fuel pump apart, and i saw no problems, no diaphragms or anything bad. I made sure it was clean, put it together, gave the carb a love tap or two in case a needle was stuck, and she ran like a champ.
 
1 - 9 of 9 Posts
Top