My Tractor Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
Yet another rookie question. I have a 2004 X495. I just acquired a 47" snow blower for it, hydraulically controlled and shaft driven. So I did get the idler bearing and mount for the long PTO shaft but I have no idea how to install it. I have searched. No luck. Does anyone have suggestion on how to install the PTO shaft idler bearing and mount that attaches to the tractor frame?
 

·
Registered
Joined
·
64 Posts
Discussion Starter #3
Thanks, wish I could find all this good stuff. I studied it a lot and you know, I am a retired engineer and I am having a heck of a time making sense of these instructions. For instance, they say "install the bracket on front left side of the frame". Ok, i got it but tell me how you "install the bracket". Maybe my brain has deteriorated past the point of usefulness. Ha!
 

·
Registered
Joined
·
64 Posts
Discussion Starter #4
I think I got it figured out. I am fearful that the front PTO idler bearing kit is missing the bearing. It looks like I have no bearing but do have two locking collars. Is there actually a ball bearing or is it a sleeve bearing which I kind of doubt. HELP please.
 

·
Premium Member
Joined
·
6,231 Posts
I got my shaft used, so the bearing was already on shaft, here is how it looks,
2446955
 

·
Registered
Joined
·
64 Posts
Discussion Starter #6
I got my shaft used, so the bearing was already on shaft, here is how it looks, View attachment 2446955
This is great! And looks just like what I got into late last night. What threw me off was the parts view showed a bearing and retaining ring whereas I have two bearing races the bolt onto the yellow handle flange. so this is extremely helpful in knowing how to assemble it so it fits right in the PTO frame kit. THANKS!!!
 
1 - 6 of 6 Posts
Top