My Tractor Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I just picked up a new to me kubota T1570 .Its seems to ok but there is a tinkling sound from the mower deck when it is engaged.When I looked at it I found a cable that is broken .The thing is I don't know what its for ,everything seems fine when I use it.I didn't get a manual with it so if anybody has any info on the cable and what it does or is suppose to do would be helpfull.Thanks in advance:thanku:
 

·
Registered
Joined
·
2,779 Posts
Welcome to MTF, glad to have you here. Good luck getting the cable figured out on your tractor.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Thanks
There is lots of stuff to look at on this sit.I may try to fix my old CO-OP Mtd tractor with all these forums here.:thanku:
 

·
Registered
Joined
·
190 Posts
I'm a Kubota owner but not all that familiar with this model. Do you have a manual or electric PTO? If its a manual PTO, my first thought would be a blade brake. Lots of companies use a cable to operate a blade brake when the PTO is in the off position.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
I'm a Kubota owner but not all that familiar with this model. Do you have a manual or electric PTO? If its a manual PTO, my first thought would be a blade brake. Lots of companies use a cable to operate a blade brake when the PTO is in the off position.
Thanks jbgtb for the reply,and yes it is manual .I was at the dealer today and got a pic of the mower and it is the brake cable that is broken.I ordered a new one should be in tomorrow which is Saturday .That would explain it almost stalling when it was engaged at low RPM.We are off to the races now.:trink39:
 
1 - 6 of 6 Posts
Top