My Tractor Forum banner
  • We have a new contest celebrating your backyard. Sponsored by Walmart, its your chance to win a $400 gift just in time for the 4th of July! HERE Contest Ends on the 30th.

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 · (Edited)
Hi everyone. I am obviously new to the forums. I usually hang out at thegsresources because I like restoring old motorcycles. I came over here to get some information for my brother in law about his John Deer 2155. It seems that it decided to stop moving. It runs fine and the loader works, but it won't move and the rear pto doesn't work. It sounds like a pump or valve to me. Any information would be appreciated.
 

·
Retired Super Moderator - Deceased September 2015
Joined
·
26,679 Posts
Glad you joined!
:wwp: If you need easy Picture help
Be sure to Register for Your State!
 

·
Former MTF Admin.
Joined
·
25,773 Posts
Welcome GSrider, good to have you here and hope your BIL gets this issue resolved. Keep checking in and hopefully some of the guys in the know will be along to offer some help :fing32:.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Thanks for the welcome. If it gets to picture time, I usually post in a link to my Picasa pictures so they can be viewed at 12MP without using up the forum resources. I used to have some land down in Spotsylvania, but had to sell it when my mother had to go into a nursing home. It wasn't too far from the lake. I'm up near Mt. Weather now.
 
1 - 5 of 5 Posts
Top