My Tractor Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello all,
Looking for some information on Iseki tractors with the Mitsubishi K3A series of motors.
I'm having a continuing issue with starting. Has always been hard to start but now it doesn't.
Replaced the fuel filter, the injection nozzles, pulled out and cleaned the injection pump. It
was fairly clean and the rail operates smoothly. Double checked the timing on the injection
pump and is within specs. Bled the system but it is only putting out fuel to the #3 cylinder.
I blew out the fuel lines when I had it apart. I've been told those injection pumps are pretty
much bullet proof but I don't know. Would appreciate any ideas you may have as I have run
out of them. Another question I have if anyone knows is if the K3A & K3E have the same bolt
pattern for mounting to the drive train. Getting harder and harder to locate parts for the K3A
and was thinking of buying a K3E series and repowering. Again, I would sincerely appreciate
any knowledge or input you may have. Thank you.

David H
 

·
Registered
Joined
·
477 Posts
Have you tried swapping a injector from like no 1 cyl and put it in 3 and see if the problem stays at 3 or follows it to no 1?
 

·
Registered
Joined
·
477 Posts
That's the best way to check to see which it is, the injector or IP. Besides that it doesn't cost anything. Also are you sure the shutoff is opening al the way to let enough fuel into the IP?

Are your glow plugs working? My engine starts hard if I don't use them.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Did what you suggested but no change. I'm thinking the IP now. I replaced the glow plugs a couple months ago, pulled them anyway
and they heat right up like they should. Pulled the fuel feed line and fuel pours right out of it. I replaced all the filters, oils & antifreeze
in September.
 

·
Registered
Joined
·
21 Posts
Not sure. Will check it out.
Been some time now so any luck?

I have an 80s IH 254 that I am resurrecting. It has the Mitsubishi K3E diesel that received new gaskets and a cleaning, now pump is off to a rebuilder because I couldn’t get fuel to No. 3 from the pump.




Sent from my iPhone using Tapatalk
 
1 - 8 of 8 Posts
Top