My Tractor Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hi All,

Quick question...My LX178 has recently started displaying the oil light after about five minutes of run time. Oil level is fine. Coolant is level fine. Performance is fine.

I'm wondering if the water pump is starting to go.

Any thoughts on where to begin would be helpful.

Thanks,
Terry
 

·
Registered
Joined
·
1,244 Posts
Is it the oil pressure light or the coolant temp light? The oil pressure light should go out within 5 seconds of starting the engine. The coolant temp light should not come on at all unless the engine is overheated. If the coolant light come on you should stop the engine innediately and determine the cause before operating the engine. Could be the water pump, or a gasket or hose...or perhaps just could be a faulty sensor. In any event check it out so you don't over cook your engine.
 

·
Registered
Joined
·
4,047 Posts
My light flickers on my LX188 from time to time. Most likely the sender becoming an issue but the Kawasaki's in the vintage of the LX100 series did use plastic cam gears.. Mine functions the same and runs flawless.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Ok guys,

A change today...the performance is not fine.

Mower quit after about 10 minutes of operating and then started again once cooled down. Prior to mowing I swapped in a new oil filter and oil level is fine. I had it laying around so I figure it wouldn't hurt. Now what are my options and the best starting place? Just a few thought below...

1) Replace sending switch
2) Check for gas in crankcase (Carb has been idling rough and surging lately which is out of character)
3) Buy oil pressure test kit (I dont know what the correct pressure should be)
4) Watch to see if water pump is moving fluid through radiator

Thanks,
Terry
 

·
Registered
Joined
·
1,244 Posts
Hi All,

Quick question...My LX178 has recently started displaying the oil light after about five minutes of run time. Oil level is fine. Coolant is level fine. Performance is fine.

I'm wondering if the water pump is starting to go.

Any thoughts on where to begin would be helpful.

Thanks,
Terry
On the LX178 there should be three dash lights. From left to right the battery, oil, and then the temp light. Was the oil light or the temp light coming on?
 

·
Registered
Joined
·
1,625 Posts
Sounds like it might be toast. Get a pressure gauge that will fit into the sending unit hole. See what pressure you have.
 
1 - 7 of 7 Posts
Top