My Tractor Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
OK, started right up yesterday as usual, I cut about half the lawn, and shut it off for a moment, then tried to start it back up.........nothing. It does not attempt to turn over, just a click at the starter. Gave the battery a charge...no change. While mowing nothing out of the ordinary took place.
Any trouble shooting would be appreciated......keep in mind I am not very technical.
Thanks
 

·
Machinery enthusiast
Joined
·
4,257 Posts
Welcome aboard psaw.
A couple swags.
1) loose/corroded battery connection(s). Make sure they are clean & tight bioth on the battery and where they connect to the starter solenoid and engine ground respectively.

2) safety switch isn't making. Make sure all your safety switches aren't loose and the wiring to them is tight and not pinched. Generally these switches are the normally open type and something has to contact the plunger inorder to close them.

3) related to the safety switches. I'm not sure of your model but some Kubota tractors will not start if the pto is engaged, or the brake/clutch isn't depressed or theres no weight in the seat. Make sure if a lever is involved that it isn't moved partially enough to where it isn't contacting the safety switch.

Good luck and let us know
Dave
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Thanks,
Battery is the issue, boosted it off the 4 wheeler, started right up. Strange how the battery went so quick.
Again thanks for the advice.:thanku:
 

·
Registered
Joined
·
386 Posts
Mine did the same thing this year, it was the orignal battery. I think it was the heat because my car did the same thing. Been danm hot here for awhile.
 

·
Machinery enthusiast
Joined
·
4,257 Posts
:thThumbsU
 
1 - 5 of 5 Posts
Top