My Tractor Forum banner
  • Are you passionate about Tractors? Would you like to write about topics that interest you and get paid for it? Read all about it here!
1 - 7 of 7 Posts

·
Premium Member
Joined
·
516 Posts
That has the "V" series engine. Basically, from what I've been able to deduce, a watered down "F" engine.

Some people haven't had any issues with them, others have had them rattle apart. I've never owned one myself so I can't attest to either but they do sound pretty good when they run.

Best thing to do is make sure all bolts have loctite on them.
 

·
Super Moderator and over 6K Posts!
Joined
·
6,405 Posts
Never had one either but thumbs up on the Loctite. Price was right!! Bill
 
  • Like
Reactions: evsnova74

·
Lawn-Boys and VW's
Joined
·
1,873 Posts
They vibrate a bit. Its kind of an F engine and kind of not. Most people pass or trash them, but had one for years and didn't have any trouble other then needing a primer bulb. Always started so, my opinion is its not a bad engine.
 

·
Registered
Joined
·
677 Posts
Discussion Starter · #5 ·
Started working on this one. The PO had used zip ties on the FW brake bracket because the cable had seized. Not sure how he was killing it. Anyway I got the cable freed up and the FW brake bail is working properly.

Then checked the gas and there was water in the gas tank from being left outside. Cleaned that out real well and figured I'd just try it even though it doesn't have a primer bulb. No dice of course. Then I tried just blowing in the primer line and I got it to kick off for a couple seconds so I figured there was no getting around having to remove the carb and clean it.

So now I've got a perfectly clean carb, of course it has water in it too, cleaned out gas tank, still no primer but you'd think if I can just get it to kick off again that a clean carb would allow it to run. Well it runs for a few seconds and dies every time now. I can even wait a little bit and start it without priming and it does the same thing. Seems like fueling to me but I only had limited time to mess with it this morning so I'll dive into it more tonight.
 

·
Registered
Joined
·
677 Posts
Discussion Starter · #7 ·
Got the primer bulb tonight, at first you have to keep it running with the primer but then it runs decently when warm. Sharpened the blade over the weekend, mows ok I guess. It's just a mower, doesn't seem very special like the older ones. Maybe that's just me. I'll keep it around for now though.
 
1 - 7 of 7 Posts
Top