My Tractor Forum banner
21 - 22 of 22 Posts

·
Registered
Joined
·
890 Posts
I just swapped the jets out and the surging subsided quite abit. The bad news it that I thought this was going to be the only problem to fix. Lets take this back a little further. I put my 10547 back in the shed after mowing with it a couple of weeks ago. It ran great at that time. I got it back out last week and it wouldnt start, I pulled and pulled. Decided to steal a coil from a donor Dura easy stride, then it started. The 10547 fired right up, but the throttle control was erratic and the surging. Since then, I swapped the pilot jet and carb. It runs with the choke on, but if I take the choke off, it really slows down to a humm. I can then take the throttle up to choke and bring it slightly down to fast and it runs ok until I hit the grass, then it slows back down. Anyone have any ideas? Unfortunately, Im thinking it may be an oil seal, but the crank doesnt look wet. Maybe its the top seal, a carb gasket? Any thing you suggest to look at? Let me know.
Thanks,
1lawnboy
Update: Tore into the 10547 this morning. Took the flywheel off and the top seal looked good. Put that back together and took the carb off once again. I thoroughly cleaned the carb. When I got done putting the carb back together I noticed that the gov. spring was broke. It was broke where you initially install it on the gov vane. I also discovered a tear in the gasket that is in between the carb and heat shield. Luckily, I had all the parts here already so I continued to put it back together. Started it up, ahhh, PERFECT!! Running a nice and smooth 3200 rpm's. What a relief! I did install the BS pilot jet and there is no surging in high or low rpm. Runs extremely smooth.
 
21 - 22 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top