My Tractor Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I was mowing the back lawn and i ran up over a large log. I heard some weird noises under the deck. the mower didnt die, so I cut it off. I pushed it off the log and started it back up, everything ran fine, cut fine. It sounded like the blades stopped spinning, but perhaps the belts kept trying to move. Is there anything I should check / worry about? I just bought the John Deere LA105 two days ago heh.
 

·
Super Moderator
Joined
·
29,532 Posts
:Welcome1:

what happened was the log jammed it tight enough the blades stopped but the belt did not. if you cut it off quickly then it may have done hardly any damage(esp since it still cuts fine). but if it smoked the belt you will get belt slippage a lot more than you should.

best thing to do is to check the deck level to make sure you did not bend anything.
 

·
9K+ Poster
Joined
·
12,160 Posts
jkeith,

Welcome to the forum! :Welcome1:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks david and JDFANATIC.

This was using a measuring tape.my right side seemed half an inch higher (rear) than the left side (rear) - But that may have been what it was from the factory, I never checked it when I got it.

Just wanted to make sure I didnt bend a blade or mess the motor up. Thanks for the reply. Guess I lucked out heh
 

·
Registered
Joined
·
1,080 Posts
Level it by measuring blades. Instruction are in your owners manual. Also make sure your on a flat and level surface and tires are at the correct pressure.
 
1 - 8 of 8 Posts
Top