My Tractor Forum banner

Kohler K301 just stopped running at fast idle

2080 Views 13 Replies 5 Participants Last post by  Baymee
Before I get too deep into this, I was warming up my 12hp Kohler to change the oil and it just stopped. I tried to restart and it just loaded up with gas and backfired.

Today, I pulled the shroud and looked at the flywheel key. The key was at 12 o'clock at TDC and appears to be in its slot. Did a leak down test and there is no leakage at TDC and both valves are opening because air comes out of both the carb and muffler.. The sound changes as the valves open and close. A new plug sparks and jumps a large gap in a tester. Direct ether does nothing, not even a kick. It has compression and suction.

With all the above info, do I have to look at wiring away from the motor? Thinking that with fuel, spark and compression, shouldn't it kick?
See less See more
1 - 14 of 14 Posts
What is it driving? Is there an interlock system on the equipment?
" I tried to restart and it just loaded up with gas and backfired."

Do you mean it flooded? I would be pulling the carb apart and see if the float is stuck
It has interlocks but it has spark. It was driving no PTO at the time. It was running fine. It backfired once and shut down.

Water in the fuel is always possible, but I can smell the gas at the carb and a shot of ether doesn't produce even a kick.
Today I pulled the flywheel and the key and position are good. The valve clearances are .009/0.18 as they should be. The carburetor had no water in it and the float seals when up. The fuel pump is new this Summer and pumps fuel. The compression is 75# when cranking. The magneto coil is gapped at 0.12 and produces spark with or without the white ground wire hooked up. I grounded the engine from the battery to the head.

I'm left with the possibility that even though the coil sparks, it still might be faulty since it's a module coil.

Any opinions? Is the coil replacement the logical next step? Remember, it was running perfectly as it has been for the last 25 years and just stopped.
See less See more
Before spending $$$ I would drain out the fuel tank...completely ...remove the plug...put a rag over hole for the plug, and over the spark plug wire end ( to prevent a fire) and turn it over a bit to clear the cylinder...put a little fuel in the cylinder that you know for certain is not contaminated, make sure the plug is dry and put plug back in and try to fire it up..if it wants to start, put some fresh fuel in the tank and see if it will start up like that
If you have confirmed spark and compression has to be something with the fuel....and with warm and then cold and then warm temps, condensation is a possibility
If you have the electrode on the spark plug wet with water it will prevent it from starting even with a good spark
See less See more
ok, my ears hurt. Did as instructed and I got a loud backfire followed by flames shooting out of the carb on each stroke. Repeated and got the same, nice blue and yellow flames out of the carb. No attempt to start. I think the engine is past the mid 80s and I can't find points on it. Only one wire going to the coil which must be the ground wire because it runs with or without the wire with the brake on.

The throttle cable rubbed off all the info on the data sticker, but I know it's a 301.
See less See more
Mystery solved. It was the module. Even though it sparked, it was either off timing or it was not strong enough.

I had noticed that it wouldn't jump the wide gap of my tester, but it gave a strong blue spark over .030. I have a spare 301 in the barn but it's cold here and I didn't want to pull the coil off and the shroud bolts aren't lubed, so I ended breaking one off.

Anyway, I braved the cold, put the new mod on, it jumped the tester gap, and started right up. Merry Christmas to me and to those who helped with this thread.

For reference, here's a case where a mod fires but won't start the engine.

Thanks all.
See less See more
edit....I was typing this while you were typing....glad you got it figured out.

I am kind of confused here....You mention magneto, you mention coil and now talk of points. I am more used to the older Kohlers with points. If it has points, they are under the cover I am pointing out in this picture. It will also have a coil that looks like a car coil. If you saw a magneto on the flywheel, it probably wont have the car coil or points.
The magneto on the flywheel needs to be set properly...The fact that you are getting that backfire tells us you have spark, just that its not at the right time......or a valve is open at the wrong time


See less See more
Any chance you can post a pic of the module setup you have?...Would be interested to see it
I wasn't sure if my engine had points until i actually looked. I remember checking the valves once before because the engine was hard to start. I would come up to compression and the starter would stop turning until it got past TDC and it wasn't related to a weak battery. Anyway, the engine in the barn was the original Wheelhorse engine and I took it off and put on the current engine which I bought at a school auction. The original was from the mid 80s and it was burning lots of oil. I removed the module and the engine started up today. In fact, I had the choke and throttle linkage disconnected and it immediately started and ran at idle with no choke used. I just wonder if this module was failing for years and I just kept using it. It would take forever to start.

Somewhere over the years, I adjusted points on a Kohler 301, I just don't remember when and it wasn't on my equipment. Maybe I'm confusing it with my JD316 Onan.

I'll post a pic of the module soon.

As to the previous u tube, I remember doing that. It used a long fiber pushrod to open the points.
See less See more
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.