My Tractor Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a Hustler ZTR mower and it started popping when it gets under load, not all of the time but will typically start when the grass is a little heavy but nothing out of the normal. I have changed fuel filter and fuel pump. I have seen suggestions that this may be a defective coil. Anyone else diagnoses something like this before I go off an buy coils.
 

·
Registered
Joined
·
309 Posts
Have you done any replacing of parts or figured out your problem?

It's possible you may need to rebuild your carb. It might be a combination of a few problems.

Float seat not seating(shutting off gas), so you have a light overflow of gas into system and unburnt gas is popping off in muffler. Good tell-tell sign is bad idle/high rpms under load or not, and black smoke coming out exhaust

Grit in high speed circuit and engine is running lean. Usually you know by loss of power, even though engine still runs smooth or a wavering of rpm's when running.

Adjust the valves? I put a question mark here as I don't know if Kawa's use unadjustable hydraulics or solid lifters to open valves.

Yes, a bad coil could be culprit if everything else in the ignition/firing circuit checks out as working. When cold it works, but breaks down when gets hot after a period of time. Coil not recovering quick enough to fire off a cylinder after its rotation cycle, but catches up on next cycle and then burns too much raw fuel in cylinder. Remove spark plugs and look. They'll be to the black side and sooty on the electrode and probably fuel wet when it happens.
 
1 - 2 of 2 Posts
Top