My Tractor Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Well, I couldn't resist...a 123 with mower deck, tiller, and a hydraulic unit all for $300. (Frankly I was looking for a Bolens, but since I have an IH Travelall I decided this would make a nice companion.)

The seller fired it up for me and I drove it around, but found that the engine ran very rough and backfired when the throttle was opened. It also doesn't want to start when warm.

I saw another thread this evening with a very similar problem that turned out to be the coil. The coil on this one is obviously new, and I suspect it's the wrong type. The coil gets quite hot when running, which tells me that this may be part of the problem. I'll get a new one from NAPA, as the person in the other thread did.

The throttle shaft also has quite a bit of play, so I'm sure there's a vacuum leak to contend with. I'll be ordering up a carb kit, and since I have a machine shop I can easily fabricate a new bushing. Should I replace the needles at the same time?

In the meantime, I suppose I should check the points and timing. One question - where are they??
 

·
Registered
Joined
·
206 Posts
Points are on the left side if youre sitting in the seat at the bottom front of the block, under an oval shaped cover.
 

·
Registered
Joined
·
469 Posts
Very common for the coil to get HOT!!! Almost as hot as the S/G. That is normal. Check the points first. Sounds like to need to put a new bushing in the carb also.
Good luck with it.
 

·
Registered
Joined
·
496 Posts
I've had two of them so far, and would allways pick up another for the right price.Super sturdy and just fun to run around,good luck on getting it worked out it's a great machine.Pics of them both plus a 70 I had ,all sold now .
Bob
 

Attachments

1 - 5 of 5 Posts
Top