My Tractor Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I am new to forums, so please don't yell at me if I did this wrong.
I have searched all references and found posts about what I am looking for.....but they are old and the links in them seem dead.
I am looking for the complete wiring diagram for a John Deere 950 (1979/80 model year.). It would need to show the rear lights also if possible.
In addition. The fuse box cover is missing....so although I can trace what wires go where, I do not know which fuses (5amp, 10amp, 15 amp) go where. I do not need to fry this harness anymore than it already is, so any help would be super cool.




Equipment:
1963 Ford 4000 Diesel (4 Cylinder) w/Massey Ferguson #41 Sickle Bar Mower
1978 Yanmar 155D w/Johnson Workhorse FEL
1980 John Deere 950 w/JD FEL #75
1980 Hustler 980 6x6 Amphibious
2010 Husqvarna Riding Mower
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
jd110.......Thank you so much. I can read the fuse one but not the wiring diagram. Is there anyway to email me a larger image file of them. They are exactly what I needed.
 

·
Registered
Joined
·
617 Posts
if you still need it, shoot me your email and I'll send you a PDF of the complete tech manual for it

Joe
 

·
Registered
Joined
·
6 Posts
I was wondering if the documents mentioned above are still available? I have been looking at the wiring diagram for my JD 950 but can only find hard to read images. I would love to get my hands on come clean PDF copies if I could. Please let me know if this is possible.
 

·
Registered
Joined
·
617 Posts
shoot me your email and it's on the way

Joe
 

·
Registered
Joined
·
617 Posts
and welcome neighbor!!!!
 

·
Registered
Joined
·
20 Posts
Wouldn't you know, I just had a 1979 950 arrive to my shop with electrical problems and need a wiring diagram also.
 

·
Registered
Joined
·
617 Posts
it's sent
 

·
Mark
Joined
·
3 Posts
Joe,
Would you be willing to send it my way as well.
Inherited my grandfathers 950. Having trouble starting. When I turn the key nothing happens, replaced switch, did some continuity testing and it seems like I might have a short somewhere int the harness.

Thanks.
 

·
Registered
Joined
·
617 Posts
send me your email

Joe
 

·
Registered
Joined
·
617 Posts
link should be there now

joe
 

·
Registered
Joined
·
617 Posts
Paul, message me your email
 
1 - 19 of 19 Posts
Top