My Tractor Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi All. Back again. I have a john deere 425, with a 20 HP Kawasaki, v twin, built in 2000. Went to start it today. I choke her and she started fine. Moved it to the back yard ,shut it down.When i went to start it, she just turns over, nothing? No spark at either sparkplug. It did the same thing last week . got it to start last week by messing with electrical connections cleaned 2 of them and it started . This time dont think thats the problem? Any ideas. Please help. Thank You Nitro 1
 

·
Super Moderator
Joined
·
33,779 Posts
Nitro, if you haven't cleaned all the grounds and connections you need to do so. You're dealing with a nearly 20 yr old tractor and it's time to go through it with the fine tooth comb. Check each connection for any corrosion and clean as necessary. Also check your battery cables (I'd do this first) and ground and see if they aren't loose.
 

·
Registered
Joined
·
62 Posts
Mine was doing the same and I kept thinking it was the connectors on the box on the left side of the engine. It ended up being the the box itself. I took a dremel tool to it and opened it up and tried to start with the electronics showing. There was sparks from where the wires were soldered to the board. I re-soldered the wires and it would start up just fine from then on but I replaced it anyway. I actually found that Jegs sells that part for ~$90. I think JD wants ~$250 for it and ebay has them for ~$170.
 

·
Registered
Joined
·
463 Posts
You might want to check out the Delay Circuit that stops the engine when you shut off the key (prevents after bang). These are notoriously failure prone components. I had something similar this spring and replaced my circuit (VERY easy, cost 28 dollars) and its perfect again.

I can't remember the exact name of the thing, but someone will chime in here.

-gh
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Thanks for all the help . Question how do you move the dead beast . feels like its in gear , and i dont know if you can put it in nutral?
 
1 - 8 of 8 Posts
Top