My Tractor Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 4100 with the Yanmar 3cyl. diesel. I noticed last winter that it wouldn't start without the aid of starter fluid. I do NOT give it much, just enough to get it to some out of the spray button. And it'll catch fire right away. If I shut it down right away, then re-start it, it fires up like its been running for hours. I haven't had to use the ether this summer. I've changed fuel filters twice since last fall (for winter service as a snow plow, and spring fluid change) so I know that's not it. I'm thinking it could be a glow plug issue. When the key is turned on, the lights for battery and glow plugs come on and then get just a little bit brighter(with a click) in about 2 seconds. Before this problem arose, I think I remember it clicking a second time and the lights getting even brighter. I've checked the fuses and they're all intact. The tractor runs like the proverbial top after it gets underway. In the summer it turns over quite a bit and when it sputters to life, it spits out white(or light gray) AND the typical black. I'm trying to be as specific as I can without anyone able to actually see it in person. Hopefully someone can help me diagnose this problem and save me some big $ by not having to go to the dealer for service. Any help is greatly appreciated!
Matt
[email protected]
 

·
9K+ Poster
Joined
·
12,164 Posts
I have a 4100 with the Yanmar 3cyl. diesel. I noticed last winter that it wouldn't start without the aid of starter fluid. I do NOT give it much, just enough to get it to some out of the spray button. And it'll catch fire right away. If I shut it down right away, then re-start it, it fires up like its been running for hours. I haven't had to use the ether this summer. I've changed fuel filters twice since last fall (for winter service as a snow plow, and spring fluid change) so I know that's not it. I'm thinking it could be a glow plug issue. When the key is turned on, the lights for battery and glow plugs come on and then get just a little bit brighter(with a click) in about 2 seconds. Before this problem arose, I think I remember it clicking a second time and the lights getting even brighter. I've checked the fuses and they're all intact. The tractor runs like the proverbial top after it gets underway. In the summer it turns over quite a bit and when it sputters to life, it spits out white(or light gray) AND the typical black. I'm trying to be as specific as I can without anyone able to actually see it in person. Hopefully someone can help me diagnose this problem and save me some big $ by not having to go to the dealer for service. Any help is greatly appreciated!
Matt
[email protected]
Matt,

I'm trying to remember if your tractor had the same starting circuit as a 2210, but if it does, try engaging the pto and turning the key and holding it in the start position for ~ 10 seconds. Then disengage the pto and start the tractor. Otherwise, maybe one of our more mechanically savvy folks will suggest a fix.
 
1 - 2 of 2 Posts
Top