My Tractor Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 430 with a problem lifting the mower deck.
It worked fine when stored last fall.
Now all hydraulics work except the mower deck lift, ie: it drives, and power steering works fine.
There is no pressure to the lifting ram when spool lever is operated.
The fluid level is at site level recommendation
when operated it does load the engine just slightly

:tango_face_wink:
 

·
Premium Member
Joined
·
2,286 Posts
Rusted?
If PS works, the hydraulics must be working.
Disconnect cylinder from linkage and see if cylinder retracts/extends.

Welcome to MTF!
 

·
Likes Vintage JDs
Joined
·
9,875 Posts
We need more info.

Is the mower deck mounted?

What position is the mower deck in - - i.e. is it all the way up or all the way down? Is the deck possibly locked in the highest position?

Is this 430 new to you? When you stored it last fall, how was it stored?

Is there possibly a lockout valve/knob or mechanical lock-out, that allows the deck lift to be locked out from that hydraulic circuit or that limits the cylinder throw?

Anything else you can tell us will be helpful.

Welcome to MTF!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
it is new to me\
was stored inside last winter and worked fine when put away
the deck will go up and down mechanically and i have been holding it at right cut height with the manual screw
how would i determine if it has a lock out valve and where would it be?
ric
 

·
Super Moderator
Joined
·
25,860 Posts
You would know if you had one because you'd have to close it to make it work. But it would be mounted on the rear lift cylinder and would be a valve with a screw that can be closed.
 

·
Premium Member
Joined
·
2,286 Posts
On my 430, for some reason, the deck lift is the middle lever. At the beginning of the season, I always grab the first lever. Maybe that lifts the snowblower, whatever!
 
1 - 6 of 6 Posts
Top