My Tractor Forum banner
  • Are you passionate about Tractors? Would you like to write about topics that interest you and get paid for it? Read all about it here!
1 - 12 of 12 Posts

·
birminghamkid
Joined
·
26 Posts
Discussion Starter · #1 ·
HI, Just brought a 1965 JD 110 today. I Can't get the brake / clutch pedal to go down. The guy had every thing working and driving it around. Got it home and now pedal won't go down. Also the lever on the other side will not move ethier. Am I doing something wrong. Any help would be great. Thanks
 

·
Super Moderator
Joined
·
39,354 Posts
Look up under the tractor where the idler for the secondary drive is at (going to the transmission. Sometimes that idler if it has some wear (and it is a 1965) will catch on something (mine used to catch the frame).
 

·
birminghamkid
Joined
·
26 Posts
Discussion Starter · #3 ·
No that's not it. Took off top cover and it's free and clear. I can pull on the belt and the pulleys move. It was stored inside so there very little rust. Got me puzzled.
 

·
Registered
Joined
·
2,041 Posts
If the "brake" lever is on it will prevent the pedal from going down if it was "turned on" while the pedal was not engaged. If I recall right.
 

·
Likes Vintage JDs
Joined
·
9,864 Posts
Congrats on the 110! Got any photos?

Wish I could offer a suggestion about the brakes, but I haven't had any issues with ours. I'll be interested to hear what the cause is.
 

·
Likes Vintage JDs
Joined
·
9,864 Posts
Now the big idler pulley in the big. Does the belt run on top of that pulley or under it.
With the secondary drive belt (the long one that goes back to the tranny), it is supposed to be led UNDER the idler pulley.
 

·
birminghamkid
Joined
·
26 Posts
Discussion Starter · #10 ·
I pulled pin out of the rocker and left springs on. Pedal goes down and back fine. So it has to do with the pulleys or belts? I can't get the variable speed lever to move at all. It's all the way forward. Do you think that has something to do with it.
 

·
birminghamkid
Joined
·
26 Posts
Discussion Starter · #12 ·
Thanks for all the help. Got it working. Between loading it in truck and unloading it the belt jumped off idler pulley and ended up being over top of pulley instead of being under. All good now.
 
1 - 12 of 12 Posts
Top