My Tractor Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter · #1 ·
Background:
Piranha by Eskimo auger model: 8907P X
Motor: Techumseh, TC II, TC300 3204G

Guys, I have a curb find ice auger that I got fired up and running. Beyond that, I haven't messed with it much. But, one possible issue that I noticed is that it doesn't seem like the motor is securely mounted to the auger panel. It looks like the mounting bolts come up from underneath the plate into the base of the motor. Before I tear into the auger mounting plate and the gears and whatever is under there, I just want to know if maybe it is not supposed to be "kind of" loose. Here is a photo of me manipulating the motor showing the movement. Let me know what you guys think.
If I have to open up the gear box for the auger, is there any thing to watch for when I open it up?
Let me know what you guys think.

 

·
Premium Member
Joined
·
6,355 Posts
I would try to find the parts diagram to see what's inside there, and then open it up.

I might expect the unit to have some kind of anti-vibration/shock absorbing system when using it, but that sounds like metal on metal contact, and that equals parts wearing rapidly when used.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #3 ·
Dave, that is what I thought as well. I haven't been able to find much on this auger on line though.
 

·
Premium Member
Joined
·
3,381 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter · #5 ·
No diagrams for the Piranha ice augers on that site. I do see some for the TC 300 motor, but it is not the motor that is the issue. It is the auger/gear box. It is an older model and they don't even list those on their web page any longer.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #6 ·
I did look at the parts diagram of one of their newer augers that use the same TC 300 motor. They look pretty similar. It doesn't give me directions for dissasembly, but the parts diagram will help. I will give it a shot and hope I don't wind up with a pile of gears and springs.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #7 ·
Guys, I got it all taken care of. I took off the bottom clutch and found the bolts to tighten up the motor head to the plate. Put it back together and it runs great and nice and solid now. Thanks all.
 
  • Like
Reactions: dave_r

·
Registered
Joined
·
125 Posts
Discussion Starter · #9 ·
Yah, I am on several forums and it is dissapointing when people come in ask for a bunch of help and advice and then disappear. I always like to post up an outcome when ever I solicit advice for a problem.
 
1 - 9 of 9 Posts
Top