My Tractor Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi, I've got a ******* Husqvarna 359 . it did have the dreaded walbro carb on it. since replaced with the zama . So it fires up pretty easy when cold approx. 3 pulls . Problem is restarting after its hot ?? I'm leaning towards a coil ?? Thanks in advance !
 

·
Super Moderator
Joined
·
8,315 Posts
Paging @WrongDoug

Let's see if he can pop in and lend a hand here.
 

·
Registered
Joined
·
2,037 Posts
I'm here, I'm here! Hot start issues can be a couple things. Usually (but not always) related to carb tuning. Have you removed the limiter caps on the carb so that you can fully adjust the screws? It could be a coil, but I would be a bit surprised if it was. It can also be a compression issue, hot compression is always lower than cold and you may not have enough hot compression to restart. What do your piston and rings look like?

The 359 is a bad-a saw, mine is my go-to for the majority of my saw work.
20200820_195348.jpg
 

·
Registered
Joined
·
3,694 Posts
The J-red version benefitted greatly to a muffler mod. The muffler was greatly restricted. Mine has had port work done and it does very well at the chainsaw races at the county fair.
 
  • Like
Reactions: WrongDoug

·
Registered
Joined
·
2,037 Posts
The J-red version benefitted greatly to a muffler mod. The muffler was greatly restricted. Mine has had port work done and it does very well at the chainsaw races at the county fair.
My muffler is gutted as well with an extra port on it. The Jonsered versions are always just a little bit cooler.
 
1 - 5 of 5 Posts
Top