My Tractor Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
When I start my loader it starts then i can rev it for a second and then it drops down to a low idle for a bit and then just dies. I know nothing about the tractor and never had an issue so far. Could this be glow plugs? Oil pressure? Fuel pump? Any help is greatly appreciated to pin point the issue, I am handy and can take direction. Thank you in advance.
 

·
Registered
Joined
·
853 Posts
When I start my loader it starts then i can rev it for a second and then it drops down to a low idle for a bit and then just dies.

Could this be glow plugs? Oil pressure? Fuel pump?
There ARE no glow plugs. No Deere engines use glow plugs except the 1010 and 2010 series that came out in 1960. Need more info, but it's most like the plastic vibration damper inside the fuel injection pump has come apart. They all do.

Symptoms will be . . . engine starts fine, then loses power, the quits. Sit for bit, it will start up, run and lose power and quite again. I've fixed hundreds of them over the years.

One note: This problem only happens with DB or JDB pumps and that's what is on the vast majority of older Deeres. But - the 500A could have two different pump models. A CBC or a JDB. CBC is small and round with a long stem sticking out of that has the throttle linkage at the end. The JDB is rectangular shaped and the throttle hooks directly to the main pump body.
If by chance you've got the CBC pump - it's been obsolete for many years and NO parts are available for it.

500A came with . . CBC431-AL, CBC431-7AL, CBC431-8AL, ... or the JDB431-AL2722
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Hi, Thanks and I just changed the injectors thinking that was the issue and the same thing is happening exactly as you say. I have the JDB - Can you let me know if I need to take it apart or bring it somewhere? Any tips help as I don't want to sink too much money into this one.
 

·
Registered
Joined
·
853 Posts
Hi, Thanks and I just changed the injectors thinking that was the issue and the same thing is happening exactly as you say. I have the JDB - Can you let me know if I need to take it apart or bring it somewhere? Any tips help as I don't want to sink too much money into this one.

The pump can be fixed for less then $40 in parts. For somebody with experience, it's a one hour job on the bench. That's to pull it apart, replace bad parts, reseal and resassemble.

If you sent out to pump shop, same job is likely to cost you $300-$600.

In my opinion, any mechanic who has good skills, and has the free pump tech manual, can figure it out. It might take 4 hours instead of 1, doing the first time. When I was a Deere mechanic, I had to fix many on site, often in the woods somewhere.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
That is good to know for sure. Here is my dilemma now. The Injection pump is leaking at the point where the cylinder feed line bolts to the injection pump. I tightened the screw and it appears not to leak anymore. I can only fire with ether and now there is black oily gas coming out of the muffler? Would that mean I have blown a piston, rings, ?? I am a little upset that I have bought a lemon and have no idea if the pump is the issue or if the engine is in trouble? I can get it started and it seems to rev but only short period and then dies (lack of fuel). Don't want to sink much into it paid $5500. Your help is great -thank you.
 
1 - 7 of 7 Posts
Top