My Tractor Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I purchase a 1964 IH Cub Cadet with Snow Thrower attachment. Tractor worked fine during the summer, but I thought it would be a good idea to have the Carb professionally cleaned and new carb kit put in it. Now the darn thing wont start. I purchased a new battery and new fuel filter and it turns over, but just won't start. Any Ideas from anyone what to do next. I'm no expert with carbs, but I am thinking the adjustment my be wrong, but it acts like it isn't getting fuel. Back to the shovel for me this year. Any help would be appreciated. Thanks
 

·
4K Poster!!!!
Joined
·
4,686 Posts
:MTF_wel2:Welcome from N.Illinois
 

·
Registered
Joined
·
1,798 Posts
Welcome to the MTF family ,neighbor.
 

·
Registered
Joined
·
1,798 Posts
Do you know of the Elkhorn Valley tractor group ? sorry if i have the name wrong . I ve seen them at a few displays and seem like a good local group for tractor enthusiasts .
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Do you know of the Elkhorn Valley tractor group ? sorry if i have the name wrong . I ve seen them at a few displays and seem like a good local group for tractor enthusiasts .
I have not heard of them, but I will do a google search to see what comes up. I eventually would like to do a complete restore on my 64 Cub, but right now I just want to get it started. :banghead3
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top