My Tractor Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter · #1 ·
Hi folks,
I have a Husky generator with a loose hanging wire ( pic 1 with arrow A)
that i do not know where is supposed to be connected and can someone
tell me what this is (pic 1 circled B )the #'s on B part are kU31107501 and 0903
the model # on electric motor is HU5005 the engine is a Subaru
the generator runs fine and has power to outlets but I'm sure their is a purpose for this wire, pic 2 is for general purpose
thanks in advance...........Daytona
 

Attachments

·
Registered
Joined
·
190 Posts
Discussion Starter · #2 ·
Did I post this thread in the wrong area of the board ?
I thought surely someone may have a possibly answer to my post,admittedly I don't post much but do read other people's post's and try to help when I can,any help would be appreciated.
Thanks, Daytona :dunno:
 

·
Registered
Joined
·
349 Posts
Sorry I don't know. My best guess is that box could be a low oil shutoff. It is possible that wire is suppose to be screwed into the hole in the block that is just to the left of it. I don't see anything else it will reach. Did you buy this generator new? Some people disconnect the oil switches because either they malfunction or they run them on an angle. The gokart and minibike guys disconnect them because they kill the engine on sharp turns.

I think generators usually have a ground wire connecting the engine to the frame as well since it is normally mounted via rubber spacers, but I think I see a green wire to the right of your second picture.
 

·
Registered
Joined
·
190 Posts
Discussion Starter · #4 ·
Thanks Shryp,
I bought it used,there was initially a wire taped to it with a wire nut on it connected to nothing and routed up on top of the engine,I looked at one at home-depot and it went on top but could not trace it,I did a search on the # that is on the black box it it came up as a "Item# RSU-KU3-11075-01
ROBIN-SUBARU ENGINE Part KU3-11075-01 / KU31107501
MODULE SENSOR FLOAT C/U CP9 " what ever that is.......
 

·
2 stroke enthusiast
Joined
·
6,568 Posts
Robin Subaru used 2 different style oil switches for the low oil sending unit. I have 2 engines using both of them. A nearly new SX-30 with the 2 wire set up and a N.O.S. '05 EX-27 with the 4 wire set up. The P.O. must have switched them or maybe a shop did? Start it up and touch the black wire to ground. If it shuts down, then isolate and insulate it. You may want to contact Robin Subaru for any other questions you have on it.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top