My Tractor Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I recently replaced the hydraulic pump due to cracked housing. I also replaced the filter obtained from Hoye.
Now the 3pt will not operate in either direction. While the tractor is running I can manual lift the 3pt with no resistance.
The UFO is not connected other then the small joystick for controlling the 3pt. It operated correctly until now.
Other than the filter I don't believe there is a screen to clean for this model.

Since I can lift the 3pt manually does anyone think the problem is mechanical vs. hydraulic?

I openned the Relief Valve & removed the Stop Valve. In both cases hydraulic fluid flowed with pressure.

Any suggestions?

BTW: Has anyone ever translated the Japanese on the UFO unit?vietvetharry

Posts: 3
Joined: Sun Aug 22, 2010 11:26 am
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #2 ·
Here are my latest findings:

I pulled the screen and found it remarkably clean. I replaced it and put back approx. 3 gallons of the drained hydfluid. I plan on adding more fresh fluid tomorrow.

After starting the tractor I tried the 3pt with the joystick control. It would not operate. I tried Ernie's suggestion to press the solenoid buttons on the control valve and it worked. The top cylinder raised the 3pt & the bottom one lowered it. I moved it up & down probably 10 times and tried the joystick every few, but the joystick never worked. I disconnected the wires between the joystick & the solenoid and was still able to raise & lower the 3pt. from the solenoid buttons.

I then tried pushing the buttons on the swing solenoid that had no wiring attached & found hydfluid leaking down the back of the casing. Each time i pressed the buttons more flowed. I will need to remove some brackets & framing to see where it is leaking. Since I do not use the swing feature does anyone know if it is possible to disable or discconnect it from the hydraulic lines?

The ground & wiring appeared secure from the control valve. Does anyone have any idea why the joystick would not operate? Would it possibly work after I finish filling with fluid? I don't see any broken wires, but I'm thinking of re-wiring since the current setup has a number of spliced sections.
 

·
Registered
Joined
·
278 Posts
I wish I had some advice, but this is uncharted territory for me. Thanks for sharing your findings though.

Bruce
 
1 - 3 of 3 Posts
Top