My Tractor Forum banner

EconoHorse Tune up

1754 Views 10 Replies 2 Participants Last post by  mla2ofus
I have a 1990 econo horse with a 6hp Tecumseh H60 engine. It has not been used in many years The fuelline was old and the breather tube had rotted through. I replace the gas line and was trying to figure out how to relplace the breather line. since it was rotted off, I could not figure out what it connected to on the engine. (i'm not too knowlogable obviously).

After figuring out what the breather was, I realized there must be some sort of connecting part that broke and was missing. there is just a 1/2 inch hole in the breather plate. I suspect there is supposed to be a part there to connect the tube to. Is that right? For a test run, i just stuck it in the breather hole and it fit in loosly. It was not connected to a fitting.

So i tried starting it up and it it was running, but roughly. it ran a couple mins and stopped. It was setting there for a few mins and I tried to start it again and it was blowing gas out of the mufler. From reading some other posts it sounnded like the gas in the muffler issue could be related to the missing connection with the breather, or do you think it is a carberator problem? Would the orginal roughness be because of no breather connection?

What should I do next. I am thinking...
1. I have to find part to connect to breather, have i ruined that if fuel got in there?
2. Possibly the gas got into the oil from what I was reading about breathers so I should do an oil change.?
3 Any other ideas?

Thanks for your help.
1 - 7 of 11 Posts
Mike, thanks for the advice. You mentioned grommet and it made me realize when i bought the new tubes I did buy 2 grommet from the parts list. I guess I was thinkng they were supposed to be hose clamps and forgot it sad grommet. Will check tomorrow, but i think got the right part. I'm not sure why the parts diagram showed 2 as the one connected the air cleaner was a normal push on type fitting with hose clamp.

I also bought a carb kit, so I can work on the needle valve. I've never done this before. Hopefully, I can find a video.

thanks again.
Update. The grommet was what i needed. The breather tube fit over it well.

I rebuilt the carburator. It was very gummed up in the bowl. While the tank was empty when it was last used. The gas in the carb probably just dried out in there.

I had a carb kit with a needle valve. I cleaned the high speed and low speed needles, and every place I could find a hole i sprayed carb cleaner. It looked much better, but I don't know if i mssed anthing.

I did not take the float off as it seem to be good and I could not figure out how to slide the pin out that holds in place. On a video i watch, it seemed vary easy, but not for me. do you pull the pin or push it out with a flat screew driver?

Anyway everthing looked much better afterwards. I reassembled. High need was backed out about 1.25 turns and high was slighly more than one turn.

So after all of this, gass is still spewing out the muffler when i try to start the engine.

What do you think?
See less See more
W/o a pic all I can tell you is to drive the float pin out w/ a small nail or punch. You've gotta see if something's wrong in the float needle and seat. I'm reasonably certain that is the problem. If the float is hollow shake it while you have it out to see if it has gas inside it.

Thanks Mike. I'll be a bit more forceful driving it out.

Another possibility is that I replaced the float needle, but did not put in a new seat. So I'll try that too.

Another issue I may be having is related to the throttle linkage to the control bracket on the front shroud. I had taken the shroud off working on the rope pull. I may have let the control bracket flip around once taking any tension off the spring. The reason i say that is the throttle lever is not in the idle position before starting. it can be half open with no tention to close it. That might be causing some flooding. I think in the start position, shouldn't there be tension put on the throttle in the closed/idle position? The throttle itself moves easily by hand so it is not stuck.
The throttle spring will pull the throttle open while the governor will pull it back toward idle to control RPM. Therefore, if the engine is stopped the throttle arm on the carb will move easily unless you have the throttle control to full speed. Yes, you could have stretched the throttle spring removing the shroud. Am I to assume you've already had the float needle out when you say you replaced the needle? Was the needle tip metal or did it have a soft plastic tip? If you have air available, try blowing back thru the fuel inlet while you have the needle out. It could have something lodged in the seat causing it to leak gas past the needle and seat.
I don't have any air availble. but while I have the needle and seat out, could i just blow carb cleaner through the inlet? I think my float needle is all metal.

So based on what you said, my linkage may be ok. It is operating as you said. I'll try cleaning as you said and put a new seat in and see what happens.
Ok, I was able to remove the pin holding the float in. And the brass float must have a leak as i could feel stuff sloshing around in it. I replaced the float and the float/needle and seat. At this point the carb is no longer flooding out and leaking gas into the exhast/breather. My oil did have gas in it so I replaced it.

At this point the engine starts pretty easily on one pull, but dies after about 5 seconds. If i try giving it more throttle it dies so I am thinking it is to rich at the low idle.

Thanks for your help so far. If any one has a link for adjusting the carb, let me know. I think i saw one stickied in one of these forumns.
Thanks everyone for your help. I ran a wire through the idle ports, but they seemed clean. I also removed a bowl nut gasket that came in my carburator kit. originally there was not one there so i tried it without one and there is no seepage at the bowl nut. The idle port is very low on the nut and suspect that it might have been partially covered by the bowl when the gasket was in place.

It is running pretty good now. I might still have adjustment to do.
1 - 7 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.